XF EFI idle - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-07-2006, 04:06   #1 (permalink)
Registered User
 
Join Date: May 2006
Posts: 12
XF EFI idle

Hey all!

Just bought a XF Wagon with the EFI engine and converted it to LPG.

It goes well on both fuels, no power loss or backfire on gas, but it has rough idle on both fuels when its in gear. (it did it before the conversion but i hardly drove it before i converted it over)

It seems very consistant like its ignition. have replaced the plugs and leads as part of the conversion, and tested the coils, seems ok.

Its my first ford (i've come from the red camp, lol), but apart from the idle its a much better car than the early shape vc & vk commodores i've had.

Any help would be appreciated

Thanks in advance.
Burg_XF is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 09-07-2006, 06:11   #2 (permalink)
Registered User
 
Join Date: May 2006
Posts: 12
Re: XF EFI idle

Also, it doesn't idle rough until the engine get to normal temp.

Thanks
Burg_XF is offline   Reply With Quote
Old 10-23-2006, 19:27   #3 (permalink)
Registered User
 
Join Date: Oct 2006
Posts: 6
Re: XF EFI idle

dude, with that sort of EFI. it will run rough at idle if it has an air leak. your engina has to be compleatly sealed. to find your INDUCTION leak, spray wd-40 over all gaskets on the induction side, if the idle changes, thats the location of your leak. they have an air flow meter, when it draws air thats not measured by the vane meter, (the black thing with wires that sits on top of the air filter) some cylinders run richer than others and an eratic idle is the result. your EC-4 has various running modes, you notice it more when its warm cause nominal run mode has engaged or the leak is heat related. first thing id check is your egr valve, it sits on your exhaust manifold and is bolted to your plenum. i have an 87 fairmont with the same ECU and have had that problem already. i have done various mods, a manual tranny with your set up rocks, i broke the 15 second barrier down the quater, not bad for an old girl, eh?
Alex.s is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:37.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.