XG ute elec problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

Australian Falcons Discuss the australian born and bred models here. Includes the 80's 90's and present day Falcons offered by Ford Oz.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-12-2011, 00:26   #1 (permalink)
Registered User
 
Join Date: Jun 2011
Posts: 6
XG ute elec problems

4 litre injected s pack auto:

Have no electrics at all, Had alt and battery tested at 14.1 volts - perfect. Was driving and just stopped dead, no lights, would not kick over or "click" total dead. Any ideas and where to look?
Trickydehn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-12-2011, 00:50   #2 (permalink)
Registered User
 
goldie1's Avatar
 
Join Date: Dec 2010
Location: Queensland,AUSTRALIA
Posts: 248
Re: XG ute elec problems

check the fuse links near the battery there is about 4 maybe 6 that come of the battery
goldie1 is offline   Reply With Quote
Old 07-12-2011, 01:28   #3 (permalink)
Registered User
 
Join Date: Jun 2011
Posts: 6
Re: XG ute elec problems

Hey Goldie,

Thanks for the reply: did check them and will replace them - does not seem the problem though. Just today it started then died almost immediately, then same problem no electrics at all again. Earth problem maybe? Do you know where to look for the neg lead that goes to earth (chassis)?
Trickydehn is offline   Reply With Quote
Old 07-12-2011, 02:10   #4 (permalink)
Registered User
 
goldie1's Avatar
 
Join Date: Dec 2010
Location: Queensland,AUSTRALIA
Posts: 248
Re: XG ute elec problems

should be under the battery i think.


Ian
goldie1 is offline   Reply With Quote
Old 07-12-2011, 04:01   #5 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,855
Re: XG ute elec problems

Attached to engine on drivers side. Also check ECU in passenger's side kick panel earth is OK. The self tapper comes loose over time giving an intermittent earth. Larger self tapper fixes it.
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Old 07-12-2011, 18:44   #6 (permalink)
Registered User
 
Join Date: Jun 2011
Posts: 6
Re: XG ute elec problems

Thanks fellas, you'll know soon enough - wish me luck.

Tricky
Trickydehn is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > Ford Cars and PAG Vehicles > Australian Ford's Discussion > Australian Falcons



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:06.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.