1993 Thunderbird transmittion problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-29-03, 01:26 PM
Posts: n/a
mad 1993 Thunderbird transmittion problem

My 3.8 liter 1993 Thunderbird has a shudder at about 20 mph if I get on it to fast. If I drive it slow, it has a lag at 30 - 45 mph. Feels as if it cant shift up. It does excelerate slowly, but it feels as if the overdrive isnt kicking on. It goes to about 3000 rpms while I excelerate to 65- 70.
I changed the filter and fluid with no change in my problem.
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Supercharged Ford Thunderbird Concept RPO83 Ford Worldwide News 1 01-02-03 09:25 PM
SHO stopper: Engine problem in high-performance Taurus angers fans Stacy94PGT Ford Worldwide News 0 10-23-02 10:39 PM
Review: Ford Thunderbird (2002) Stacy94PGT Ford Worldwide News 0 08-30-02 10:48 PM
1993 Tempo GS Power locks problem agoulet Ford Tempo Forum | Mercury Topaz Forum 0 05-21-02 08:05 PM
Thunderbird - Motor Trend COTY RPO83 The Pub 4 11-22-01 05:09 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome