1997 Taurus overdrive not working? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-24-2007, 21:13   #1 (permalink)
Registered User
 
Join Date: Dec 2007
Posts: 5
1997 Taurus overdrive not working?

Hopefully this is the right section to post this in. If it's not, please delete it or move it. Thanks!

I have a 1997 Ford Taurus GL. I currently have a CEL but that's for the cat converter. I've noticed that driving on the highway recently, the rpms are at about 36-3700 at ~70mph. Also, just from driving it around town I've noticed that it's not shifting to make the rpms lower, a.k.a. overdrive, right?

There's no speedo jumping or anything like that, so I'm not positive it's VSS related, however, the tranny shifts fine, which leads me to think it's something electrical. I'm just not too familiar with Fords to know.

Anyone have an idea? Thanks a ton for the help!
TurboGoKart is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-24-2007, 21:14   #2 (permalink)
Registered User
 
Join Date: Dec 2007
Posts: 5
Re: 1997 Taurus overdrive not working?

Really weird thing......I was just driving an hour on the highway today. I didn't even realize until I had been driving a half an hour that overdrive was working.

So I know it's not mechanical. Just not sure how the overdrive works to know why it would work sometimes and not work other times.
TurboGoKart is offline   Reply With Quote
Old 12-26-2007, 16:54   #3 (permalink)
wasnt me
 
390wagon's Avatar
 
Join Date: Oct 2004
Location: new hampshire USA
Age: 31
Posts: 281
Re: 1997 Taurus overdrive not working?

should be a solenoid pack in the transmission, overdrive solenoid may be sticking, how the fluid look?
__________________
68 Ford Country Sedan Wagon-390 FE, C6, 9 Inch
87 Chevy Caprice Classic Wagon-307, 2004R, 10 Bolt, what can i say, i grew up with that car
390wagon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:36.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.