65 Ranchero c4 Linkage question - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-21-05, 12:31 PM Thread Starter
Registered User
Join Date: Aug 2005
Posts: 4
65 Ranchero c4 Linkage question

Just had a new 289 longblock put in by local mechanic. The tranny seem to shift at different points now. 1-2 ~30mph, 2-3 ~50+. Acts this way under light or heavy throttle. Definately not the way it was before they touched it. Before it would shift up through 2 and 3 at low speeds under low throttle - not now. What's up? Linkage adjustment? Auto Kickdown adjustment?

Also, the mechanic suggested to block the water bypass hose in the radiator hose attaching piece on the front of the intake manifold for increased cooling - this seemed very odd to me - thoughts?

Help - any thoughts appreciated.

scottmachado is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome