95 Ranger 2.3l clutch prob - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-28-05, 01:42 PM Thread Starter
Registered User
Join Date: Apr 2005
Posts: 2
95 Ranger 2.3l clutch prob

Not sure if I posted this in the correct forum earlier (Ranger), so thought I would try here since I haven't received any responses there.

My Ranger's clutch jams/sticks disengaged at times. Usually after driving 5-10 miles. Most of the time I can make it work correctly for a short time by putting it in neutral and letting the clutch pedal pop back to the top. At one point I was checking the fluid level, hopped in and pumped the clutch 5-6 times and the clutch pedal pumped up and jammed at the top and could not be pressed back down. The clutch was fully disengaged and I could shift to any gear without engaging the transmission. The fluid reservoir level went from full to almost empty. I stomped on the clutch as hard as I could and moved the truck around and it was suddenly free again and the fluid level was back up to full. It felt like I had pumped up the hydraulics and a check valve wouldn't release the pressure. I see there is an "All Data" list for a TSB 97-22-17 relating to a "Hard to depress/premature slave cylinder wear", don't think that is Fords TSB number though.

Any knowledgeable advice to fix the problem? It only has
34k miles on it.
birdman is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome