auto slipping/changing slow - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 06-19-2005, 23:57   #1 (permalink)
8 cylinder symphony
 
b-juggles's Avatar
 
Join Date: Mar 2002
Location: Sydney
Posts: 1,348
auto slipping/changing slow

when I engage D (from say park) it takes 2-3 seconds to engage. It does the same from D to R.

Also, for example when I have it in first gear, and accelerate, it slips for a bit and then takes up...the oil is cherry red and there is enought oil in the box (according to the dipstick) does that sound like the bands are slipping and it simply needs a service or does it sound like something worse?
b-juggles is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 06-27-2005, 00:13   #2 (permalink)
Registered User
 
atec77's Avatar
 
Join Date: Feb 2005
Posts: 917
Re: auto slipping/changing slow

Quote:
Originally Posted by hot_eb
when I engage D (from say park) it takes 2-3 seconds to engage. It does the same from D to R.

Also, for example when I have it in first gear, and accelerate, it slips for a bit and then takes up...the oil is cherry red and there is enought oil in the box (according to the dipstick) does that sound like the bands are slipping and it simply needs a service or does it sound like something worse?
moer information , which box / car/ motor ?
atec77 is offline   Reply With Quote
Old 07-03-2005, 02:22   #3 (permalink)
Registered User
 
Join Date: Jun 2005
Posts: 6
Re: auto slipping/changing slow

[QUOTE=hot_eb]when I engage D (from say park) it takes 2-3 seconds to engage. It does the same from D to R.

Your EB should have a BTR85 Tranz, I would replace the S5 Solinoid as the first signs of failure is when they delay into reverse.
If it is a 3 spd you may find the seals are old.
Tranzman is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 05:07.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.