C-4 transmission won - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-07-12, 04:12 PM Thread Starter
Registered User
heyitsmesmitty's Avatar
Join Date: Dec 2006
Location: Cape Cod
Posts: 16
C-4 transmission won

Hello everyone! Hoping someone might be able to help me with my transmission problem.. I have a 1966 Ford Fairlane, 302 ci motor, and C-4 Trans. I just finished up buiding up my motor, and took it out for a drive, and it wouldn't shift into 3rd gear! 1st and 2nd was no problem, seemed normal, but 3rd never came. Even when i went trough the gears on the column, still couldnt upshift. Not sure what the problem is.

Checked my kickdown cable, wasnt stuck; that vacuum tube from my manifold, and i assume goes to my transmission, wasn't kinked or anyhing. Not sure what this vacuum line goes too. And the fluid level is good.

Any information would really help me out!

heyitsmesmitty is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome