C4 problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 09-20-05, 01:11 AM Thread Starter
Join Date: Apr 2005
Location: The Oaks, NSW, Australia
Posts: 42
C4 problems

Hi guys just finished puting the engine back together. closed chamber heads, 4v valves, new cam, springs, lifters. Put a shift kit in it took it for a test run and it goes from 1st to 2nd and if i put my foot down it locks up and brings me to a stop, then it will go to 1st and i can crawl home. any suggestions what could be wrong with it. i was thinking possibly that the vacuum modulator or theres not enough vacuum. any suggesstions would be grateful.

1923 Ford T-Bucket

351 Cleveland
Twin 450 Holleys
Cain Tunnel Ram Manifold
C4 Box
Fat 305s on the rear

mr t is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome