Clutch Help Needed - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 08-01-05, 05:41 AM Thread Starter
Registered User
Join Date: Dec 2004
Location: Melbourne
Age: 30
Posts: 47
Clutch Help Needed

Currently When ever I accelerate hard and get enough wheel spin, I have a problem where the clutch pedal goes mushy, and stays on the floor once pushed in again for a little while. After a little while I suspect the engine may just be revving and no drive going to the wheels.
Does anyone know the reason for this??
Could something need adjusting?
This has been happening after I changed gearboxes, but is definetly clutch and not a gearbox problem.
My car is an xe with a 351 and 4spd single rail. Its the hydraulic type clutch too.

F399 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome