EAGhiaII Auto advice please!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
» Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-21-2004, 07:04   #1 (permalink)
Krissy
 
AU_Fairmont -S-'s Avatar
 
Join Date: Nov 2003
Location: Melbourne
Age: 41
Posts: 285
EAGhiaII Auto advice please!!

Hi ...

I need some advice on my Auto. (I have an 89 EAGhiaII 4spd auto) The other day I was driving on the Ring Rd (doing 100k's) and with no warning, the car just rev'd out loudly and the speedo went to "0" (while driving). It didn't drop gear, it felt more like it had gone into neutral and it just slipped back into gear (no hard banging) It rev'd out for about 2-3 seconds then comfortably went back into gear. This has never happened b4. I had a trans sevice about 2 months ago. It's only done it that once BUT it's obviously a lead up to a problem. Being a female, I'm worried about taking it to an Auto place without some advice from here first bcoz I don't wanna be ripped off. I'm thinking it's a solanoid? I had this Auto fitted about 4 years ago (changeover)

Any advice or suggestions would be really appreciated ... thanks :o)
__________________
One more repo and I'll be debt free!

AU_Fairmont -S- is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-21-2004, 16:30   #2 (permalink)
Looking in YOUR bathroom.
 
Join Date: May 2002
Location: Adelaide
Age: 30
Posts: 3,287
Re: EAGhiaII Auto advice please!!

if spedo droped to zero it sounds like a dead/dieing spedo drive. IF that goes the computer doesnt know what gear to be in.
__________________
Ive been described as a vault of usless random knowledge.

Ill take it as a complement i think.............
Walkinshaw is offline   Reply With Quote
Old 03-21-2004, 16:58   #3 (permalink)
NZ
feed me hey
 
Join Date: Jul 2002
Age: 64
Posts: 4,692
Re: EAGhiaII Auto advice please!!

it should have gone into 3rd if it had no speedo signal
__________________
Dot Aye You
NZ is offline   Reply With Quote
Old 03-21-2004, 18:53   #4 (permalink)
Krissy
 
AU_Fairmont -S-'s Avatar
 
Join Date: Nov 2003
Location: Melbourne
Age: 41
Posts: 285
Re: EAGhiaII Auto advice please!!

I rang the guys at Transtyle (they fitted my Auto) and I didn't tell them the advice I was given on here and they told me straight out "sounds like your speedo sensor" $85 and all will be better tomorrow. So I know I'm not being ripped off!!

Thanks heaps :o)
__________________
One more repo and I'll be debt free!

AU_Fairmont -S- is offline   Reply With Quote
Old 03-24-2004, 01:30   #5 (permalink)
TQE FAIRMONT GHIA
 
BOON250's Avatar
 
Join Date: Jul 2002
Location: Auckland NZ
Age: 34
Posts: 457
Re: EAGhiaII Auto advice please!!

Quote:
Originally Posted by -FPV_FPR-
I rang the guys at Transtyle (they fitted my Auto) and I didn't tell them the advice I was given on here and they told me straight out "sounds like your speedo sensor" $85 and all will be better tomorrow. So I know I'm not being ripped off!!

Thanks heaps :o)
Alls well then!!!
__________________
1994 Fairmont Ghia ED Built 6/94 4.0 I6 Auto Full Leather Premium Sound Poly Green Clear Indicators AU3 Clear Side Repeaters Lowered Tints "OK LETS ROLL"
BOON250 is offline   Reply With Quote
Old 04-04-2004, 07:58   #6 (permalink)
Krissy
 
AU_Fairmont -S-'s Avatar
 
Join Date: Nov 2003
Location: Melbourne
Age: 41
Posts: 285
Re: EAGhiaII Auto advice please!!

What about with the EL Frmnt Ghia's ... Does the same thing happen when the speed sensor is on it's way out? Does the speedo go to zero like how mine did?
__________________
One more repo and I'll be debt free!

AU_Fairmont -S- is offline   Reply With Quote
Old 04-04-2004, 08:11   #7 (permalink)
Look! A flying orangutan!
 
Join Date: Mar 2003
Location: perth
Age: 31
Posts: 3,104
Re: EAGhiaII Auto advice please!!

Also try the earth strap between the box and the passenger floor. A bad earth can cause similar symptoms.
__________________
Proud TQE Operator and President of SEFAG - the Society for the Elimination of Ford Automatic Gearboxes

Pacemaker headers + 2.5" exhaust
EF Fairmont interior
MP3 player
Lowered King springs
5 speed manual
EF motor

Newest mod: EF Ghia wiring loom and dash
mongrelEB is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Manaul v auto XRchic F6 Typhoon | XR6 Turbo 27 03-27-2004 13:30
The Year was 1976 .... russellw The Pub 21 03-15-2003 09:13
Bad outlook drives auto stocks down Stacy94PGT Ford Worldwide News 0 03-04-2003 22:37
This Years Chicago Auto Show Strives to Dazzle Car Lovers Stacy94PGT Ford Worldwide News 0 02-04-2003 20:18

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:03.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.