I think my BTR has died :( - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 12-09-04, 05:33 PM Thread Starter
5.0 ED Wagon
 
banarcus's Avatar
 
Join Date: Sep 2003
Location: Orange NSW
Age: 42
Posts: 123
I think my BTR has died :(

My ED V8 wagon has the 4 speed auto. Regular services, only the inhibitor switch has been renewed. On my recent trip to Maitland from Orange, the car has been slow to respond when I change from neutral to drive. It has slowly been getting worse from about a 3-4 days ago.

I get to Maitalnd and now I've lost all my forward gears in one foul swoop. Nil, zip, nothing.
I still have reverse but thats it. This at least rules out the torque convertor.

Anyone here on the forums had this problem with either the six or the 8? I thought that at least I'd have 3rd gear with that limp home mode but I get absolutely nothing. BTW, as I saud before, the thing is always regularly serviced and its fluid/levels are spot on. I'm stuffed if I know whats wrong???
Please help...
mark...


banarcus is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 12-13-04, 02:09 AM
mmm..Vee 8
 
Join Date: Jul 2002
Age: 33
Posts: 496
Re: I think my BTR has died :(

what was the end diagnosis banarcus?

Extreme

First Ever Car - '84 XF Fairmont Ghia....Big Luxo Tank, Just Gotta Love that Velour!
Previous Ride- '87 XF S Pak...Now Retired with 305,000 on the clock!
Previous Ride-'99 AU Falcon S,Got sick of the 6...Need a V8!

5/1994 ED Futura Classic 5.0 in Polyneisan Green - One of the last ever built
Extreme_2020 is offline  
post #3 of 6 (permalink) Old 12-13-04, 02:34 AM Thread Starter
5.0 ED Wagon
 
banarcus's Avatar
 
Join Date: Sep 2003
Location: Orange NSW
Age: 42
Posts: 123
Re: I think my BTR has died :(

Mate, in the end I checked the linkage adjustment to see if that was the problem. The NRMA bloke said that the fluid appeared to be burnt so I decided to pull the gearbox out (only took 2 hours) and the pedal box, t bar, transmission cooler, lines etc. I'm picking up a T5 tomorrow with all the gear. The box is from a 96 EL. Going to fiddle around with all the wires tomorrow night and see how it all goes. Should be fun anyway with it being a very unique car. Cant wait to drive it, its gonna be an absolute ripper, just wish I had another 2 grand to spend on the motor...

Going to sell the old box and all the other auto junk for $50 if there are any takers.

banarcus is offline  
post #4 of 6 (permalink) Old 12-13-04, 02:16 PM
do YOU have rubber?
 
!Gn|T|0n's Avatar
 
Join Date: Dec 2002
Location: Brisbane
Age: 36
Posts: 2,357
Re: I think my BTR has died :(

Where did you pick up the V8T5 and how much did it cost you if you don't mind me asking.
!Gn|T|0n is offline  
post #5 of 6 (permalink) Old 12-14-04, 02:10 AM Thread Starter
5.0 ED Wagon
 
banarcus's Avatar
 
Join Date: Sep 2003
Location: Orange NSW
Age: 42
Posts: 123
Re: I think my BTR has died :(

Funny you ask ignition. I ended up getting a T5 from a fella in the tow truck, smash industry in Sydney with the console boot rubber surround, brand new pedal box with switches and a new clutch cable all for $750. All I need is the clutch and to fiddle with the wiring and a gear knob . Flywheel wasn't cheap though, it cost me $450, apparently because the 5.0L is externally balance d through the flywheel counter weight.

Our mate ebxr8240 had one going for $1000 but I missed out on that one. Could've been mine though if only he answered his mobile :).

banarcus is offline  
post #6 of 6 (permalink) Old 12-14-04, 02:11 AM Thread Starter
5.0 ED Wagon
 
banarcus's Avatar
 
Join Date: Sep 2003
Location: Orange NSW
Age: 42
Posts: 123
Re: I think my BTR has died :(

Funny you ask ignition. I ended up getting a T5 from a fella in the tow truck, smash industry in Sydney with the console boot rubber surround, brand new pedal box with switches and a new clutch cable all for $750. All I need is the clutch and to fiddle with the wiring and a gear knob . Flywheel wasn't cheap though, it cost me $450, apparently because the 5.0L is externally balance d through the flywheel counter weight.

Our mate ebxr8240 had one going for $1000 but I missed out on that one. Could've been mine though if only he answered his mobile

banarcus is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
All lights/elec.sys died when starting engine yfradkin Interior | Electrical | ECU 0 10-30-04 07:37 PM
Commonsense Has Died smciner1 The Pub 15 05-19-04 06:52 AM
Who died the worse death? Joke. FordHawk The Pub 3 01-10-04 11:16 PM
EA died again, can anyone help? Chad_XF Interior | Electrical | ECU 9 10-26-03 01:27 AM
car died while driving.. tacho went to 0.. no go now eskyboi General Tech 18 08-17-03 08:38 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome