LinkBack Thread Tools Display Modes
post #1 of (permalink) Old 10-30-04, 11:15 PM Thread Starter
Ford Member
Join Date: Jun 2003
Location: Brisbane
Age: 29
Posts: 87
mainshaft spigot bearing on t5?

hey all, has anyone ever had this bearing go on thier t5? i have eb1 factory t5, did the bbm conversion, got a lumpy custom cam and some 4480 pacemakers and took it for a flog. raced all day with mates and was very happy. on the way home i got a bad vibration through the stick. i pulled over and had in nuetral running poped the bonnet and it just sounded like a really bad knock, got back in put the clutch in and it dissapears. so i assume a bearing?? i know this is a result of my style driving, but has anyone else encounter simmilar?

thanx in advance
falcon_boy is offline  
post #2 of (permalink) Old 11-02-04, 03:29 AM
Dirt Tracker
Join Date: Jul 2004
Location: rosebud
Posts: 83
Re: mainshaft spigot bearing on t5?

it sounds like it may be your thrust bearing raqther than your spigot
dirt tracker is offline  
post #3 of (permalink) Old 11-06-04, 04:16 PM Thread Starter
Ford Member
Join Date: Jun 2003
Location: Brisbane
Age: 29
Posts: 87
Re: mainshaft spigot bearing on t5?

well, there are actually a few bearings to be replaced in it. i pulled it out friday and stripped it down, the real problem is the 2 teeth missing on 2nd gear countershaft and some big gouges on 3rd. so im off to get a big list of parts......
falcon_boy is offline  

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Vibration a/c main bearing or ????????????? EL MCFALCON General Tech 1 10-26-04 08:27 AM
Front wheel bearing cre2002 General Tech 1 10-04-04 04:57 AM
EF Power steering pump - replacing bearing back2thefutura Inline 6 Tech 6 07-02-04 01:04 AM
front wheel bearing help Diggar Suspension | Wheels&Tires | Brakes 1 05-07-04 02:50 AM
Spigot bearing... Wez General Tech 8 07-01-03 10:18 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome