T5 tranny troubles - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 07-03-02, 06:25 PM Thread Starter
Registered User
 
Join Date: Jun 2002
Location: Werribee Australia
Posts: 13
T5 tranny troubles

ive got a XLS 5.o ute, in my T5, 5th gear synchro went at 70,000, took dealer 7 days to get the parts and get my car mobile, its done 2500 Ks since and the same synchro is rooted, dealer says they will fit a new T5, its been 7 days now and still no reply, hows that for customer service

any one else had T5 troubles similar to mine

im a die hard ford fan atic, but shit like this makes u wonder this dont help sales at all

if any dealer reads this:pull your #%^* socks up and lets beat the opposition
Evil 5.0 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 07-05-02, 02:57 AM
Registered User
 
Join Date: Jul 2002
Location: In hiding
Posts: 864
It's not much consolation but you aren't the only one. Like you, I'm diehard Ford and I will accept that sometimes things break that shouldn't. However it really irks when it can't be fixed. If something breaks, FIX IT, How hard can it be? Very hard it seems for Ford these days. And not only Ford either - this is an endemic problem throughtout the motor/spare parts industry.

I've been waiting 10 weeks for a new gearbox and clutch - luckily what I have is still going but don't know for how long. Oh well, when it finally carks it they can sent a truck and pick it up - when it starts costing THEM money they might finally do something about it.
T3man is offline  
post #3 of 6 (permalink) Old 07-07-02, 05:40 PM Thread Starter
Registered User
 
Join Date: Jun 2002
Location: Werribee Australia
Posts: 13
Hey T3 Man,
is that also a T5 that you've got, its been a week on friday, the service manager reckons hes waiting on an answer from BTR Albury, i wonder how long its gonna take
Evil 5.0 is offline  
post #4 of 6 (permalink) Old 07-08-02, 05:43 AM
In a blue Galaxy
 
Cobra's Avatar
 
Join Date: May 2001
Location: Geelong, Victoria
Posts: 5,716
Quote:
Originally posted by Evil 5.0
Hey T3 Man,
is that also a T5 that you've got, its been a week on friday, the service manager reckons hes waiting on an answer from BTR Albury, i wonder how long its gonna take
If I may ask, which dealership is this?

O.F.R #12
1999 AU XR8
14.594 @ 94.40mph
152.2RWKW (APS dyno)
Switchable Shift Kit, K&N panel filter, Lukey straight thru mufflers, momo gear and steer,
DBA slotted rotors/Bendix ultimate pads (front), Pioneer MP3 head unit and BA XR carpet mats.

Member of the Society Against Stupid SMS Language
Cobra is offline  
post #5 of 6 (permalink) Old 07-08-02, 09:18 AM
Registered User
 
Join Date: Jul 2002
Location: In hiding
Posts: 864
Mine's a Tremec 3650 - they are apparently waiting on parts from the States - this is what they're feeding me anyway.
But a friend of mine has an XR6 with a T5 and it's a dead'n as well, and BTR have told her the noises it's making are normal. BS. The local Ford dealer is on her side but he is being overridden by someone above, either at Ford Warranty or BTR.
T3man is offline  
post #6 of 6 (permalink) Old 07-11-02, 01:03 AM
Registered User
 
Join Date: Jun 2002
Location: Queensland
Posts: 24
Trust me t3man they are feeding you crap because tremec parts don not take 10 weeks to get here. They should be in stock in melbourne.
6speedxr8 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Probe tranny woes Mellow-D Ford Probe Forum | Mazda MX6 Forum 19 08-02-13 07:50 PM
Metal Shavings in Tranny Pump mean bad Tranny Pump?? Custom GT Ford Probe Forum | Mazda MX6 Forum 12 12-24-01 11:41 PM
Tranny fluid additive!?!?! Allen Ford Tempo Forum | Mercury Topaz Forum 6 08-25-01 03:27 AM
Manual Tranny probs at low revs xrthrasher Trans | Driveline 11 06-18-01 03:35 PM
Im in need of tranny info.............. RPSH8R The Pub 0 04-22-01 07:30 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome