Transmission ? Will not accelerate over 50 even when floored - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-19-05, 07:33 PM Thread Starter
Registered User
 
Join Date: Jul 2005
Posts: 1
Transmission ? Will not accelerate over 50 even when floored

I have a problem that just started. 2002 ranger 50k miles - as I floor the accelerator the rpms reach about 3500 and stop the transmission doesn't seem to shift. if i hold the petal to the floor, at times, the valves start tapping excessively, then other times not, but the truck will ultimately not accelerate past 50mph - very slow to reach 50 - almost like i am towing a house
any help is greatly appreciated
jaggedmedia is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 03-12-07, 06:14 PM
Registered User
 
Join Date: Mar 2007
Posts: 3
Re: Transmission ? Will not accelerate over 50 even when floored

POSIBLY A BLOCKED CATALYTIC CONVERTER. I DIGNOSED THIS IN A MUSTANG BY DISCONNECTING THE DOWN PIPE BEFORE THE CONVERTER AND RESTORED THE USUAL POWER OUTPUT- AND IT WAS UNDER THE 75K EMMISSIONS WARRANTEE.
sb
escotland is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome