XR8 auto gear position fault ? (detailed) - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 02-11-2003, 21:51   #1 (permalink)
Registered User
 
Join Date: Feb 2003
Posts: 78
XR8 auto gear position fault ? (detailed)

My EL XR8 has an intermitent fault with the auto, with which the gear position appears to be lost momentarily. WHen it occurs it has the effect of allowing the engine to rev well past its normal shift point (under full throttle), or almost stall at idle, as the idle rpm isn't increased for being in gear. WHen this happens you can manually still select other gears. At other times everything behaves normally.

As part of my troubleshooting, i have had the odometer in the 'diagnostic' mode, but this has shown no pattern in the cause. It can occur if the engine is hot or cold, engine running or not running. As well as showing 'd' when in reverse (for example), the odometer display may show '0', presumedly as it has no idea of what gear is selected at all.

The fault codes i obtained from the trans were:
27 - shift lever input fault
67 - data output link fault - 8 cyl (I am aware that code 67 will be generated if you do the trans and engine self tests incorrectly, but i did this so as not to generate the fault that way).

Jiggling the wire connectors at the inhibitor/gear selector switch on the trans, and the trans ECU appeared to eliminate faulty connections, and the trans oil is clean.

I tend to think that it may be the inhibitor/gear selector switch on the side of the trans at fault, but i am unsure why this would produce the "data output link" fault. Has anyone else had this problem (and solved it !) ? Thanks
EL1XR8 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 02-12-2003, 03:54   #2 (permalink)
345kw of V8 Windsor Power
 
EDXR8's Avatar
 
Join Date: Jul 2001
Location: Adelaide
Age: 35
Posts: 2,784
I had the same problem and it was the neutral safety switch (inhibitor/gear selector switch). By memory, they are about $60 from ford and only take about 5 mins to fit.
EDXR8 is offline   Reply With Quote
Old 02-13-2003, 12:44   #3 (permalink)
Registered User
 
Join Date: Feb 2003
Posts: 78
Thanks for the info.
EL1XR8 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > Trans | Driveline



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Drive article: XR8 vs SS FPRXR-6 Australian Falcons 32 02-22-2005 04:48
AUII XR8 Auto recall kiwi Trans | Driveline 8 01-05-2004 21:47
0-100km in AUII 220kw XR8 with AUTO GTPChris The Pub 26 07-09-2003 01:41

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 18:00.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.