2.9 bronco II idle problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 09-13-2004, 14:45   #1 (permalink)
Registered User
 
Join Date: Sep 2003
Age: 54
Posts: 4
2.9 bronco II idle problems

My daughters Bronco II will not idle properly, When first started hot or cold it will rev to 2000 rpm then slowly drop until it dies. Restart and it will rev to 1500 rpm then slowly drop to about 1200. It will then hunt back and forth about 300 rpm. The computer is throwing no codes and I recently rebuilt the heads replaced the plugs wires and cap also. I was getting codes and have replaced the egr valve and position sensor. Any ideas out there?
butch is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EF Fairmont idle problems toby123 Inline 6 Tech 5 07-23-2003 07:22
Ford Bronco II rollover lawsuits may be reheard as expert witness is challenged RPO83 Ford Worldwide News 1 04-23-2003 09:08
AU II Diff problems?? AU_guy The Pub 19 09-27-2001 05:38
idle problems rebland Ford Bronco Forum 2 07-24-2001 15:47
1987 Bronco II water pump rgcopeland Ford Bronco Forum 2 03-25-2001 18:39

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 04:26.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.