2 Problems With 1998 Windstar - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 10-18-06, 08:36 AM Thread Starter
Registered User
 
Join Date: Oct 2006
Posts: 1
2 Problems With 1998 Windstar

1. Loud whining sound coming from one of the wheel areas once car has been
driven for a while. Sound goes away when brake is applied. When stopped I
can feel a large amount of heat coming from wheel area and a slight smell.

2. Loud hydraulic sound when turning car to the left. Doesn't happen when
turning to the right.

Does anyone have a suspicion as to what the issues might be here? Thanks in advance for your help!

gatorinsc is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 10-18-06, 09:10 PM
Hi-Tech Redneck
 
Johnny Mullet's Avatar
 
Join Date: Jun 2006
Location: Ashtabula, Ohio
Age: 46
Posts: 1,486
Re: 2 Problems With 1998 Windstar

The noise in front while driving could be a bad wheel bearing hub assy.

The steering noise could be low P/S fluid or air in the system.
Johnny Mullet is offline  
post #3 of 3 (permalink) Old 10-19-06, 06:57 PM
Always the student
 
thefonz's Avatar
 
Join Date: Jul 2006
Posts: 1,738
Re: 2 Problems With 1998 Windstar

I'm with Mullet Man on this one. Don't ignore the wheel bearing,if that's what it is. Seen them get welded to the spindle
thefonz is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome