84 5.0 VERY high idle when cold - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
¬Ľ Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-10-2004, 20:04   #1 (permalink)
Registered User
 
Join Date: Dec 2004
Age: 33
Posts: 2
84 5.0 VERY high idle when cold

Hello, im new here and recently picked up my 2nd and 3rd thunderbirsd. my firsts sadly in the junk yard, it was an 83. i just got a 84 and an 88 parts car.

my problem is the 84, its got that throttle body injection i believe its called (looks like a carb with injectors in it) when the cars first started it idles wicked fast, it eventually slows down to the correct speed after a while. any ideas on what the problem could be? i hope to make this car my daily driver asap if i get it running well. the car has been sitting in a garage for a couple years if that means anything at all.

im not new to fixing cars, give me a motor with an old fashioned carb and im good to go, but once theres a computer involved, its new to me, thanks, Mike
84bird is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
High idle burnit General Tech 9 12-05-2004 17:32
high constant engine idle midnightstar03 Ford Tempo Forum | Mercury Topaz Forum 4 08-14-2004 20:42
Worked i6 idle and oil pressure issues... Ideas? defective Inline 6 Tech 18 07-23-2004 17:11
Too cold!? Martin General Tech 5 02-08-2002 07:39

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:41.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.