94 Aerostar bad idle - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-18-2008, 04:32   #1 (permalink)
Registered User
 
Join Date: Jan 2008
Posts: 4
94 Aerostar bad idle

I have a 94 Aerostar 3.0L V6 with 172000 miles on it. The idle is rough mostly when cold but also some times when warm. I replaced the spark plugs and plug wires, not real sure the wires were bad. This helped maybe a little but still get some bad idling both cold and warm. Any ideas what's up?
paulwwww is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 01-19-2008, 15:07   #2 (permalink)
wasnt me
 
390wagon's Avatar
 
Join Date: Oct 2004
Location: new hampshire USA
Age: 32
Posts: 281
Re: 94 Aerostar bad idle

i would throw some injector cleaner in the gas tank(techron) and clean the throttle bore first then i would suspect the idle air control solenoid is either carboned up or just plain dying.
__________________
68 Ford Country Sedan Wagon-390 FE, C6, 9 Inch
87 Chevy Caprice Classic Wagon-307, 2004R, 10 Bolt, what can i say, i grew up with that car
390wagon is offline   Reply With Quote
Old 01-20-2008, 08:56   #3 (permalink)
Registered User
 
Join Date: Jan 2008
Posts: 4
Re: 94 Aerostar bad idle

Thanks for the information, and sorry I was a little slow getting back out here. I will try the injector cleaner first. When you mention cleaning the throttle bore, does this entail removing the throttle housing? Any info is great, thanks...
paulwwww is offline   Reply With Quote
Old 01-27-2008, 15:38   #4 (permalink)
wasnt me
 
390wagon's Avatar
 
Join Date: Oct 2004
Location: new hampshire USA
Age: 32
Posts: 281
Re: 94 Aerostar bad idle

just take off the air filter and whatever hose there is(i dont remember how the aerostar is set up) and clean around the throttle bad with a rag and carb cleaner.
__________________
68 Ford Country Sedan Wagon-390 FE, C6, 9 Inch
87 Chevy Caprice Classic Wagon-307, 2004R, 10 Bolt, what can i say, i grew up with that car
390wagon is offline   Reply With Quote
Old 01-28-2008, 18:25   #5 (permalink)
Registered User
 
Join Date: Jan 2008
Posts: 4
Re: 94 Aerostar bad idle

Excellent info thanks, pulled the hose off and sprayed some throttle/air intake cleaner spray in and around the throttle plate, and wiped out a bunch of the gunk. It was filthy, preliminary drive around the block appears to have fixed the problem. Hopefully this will be the fix I was looking for, thanks again...
paulwwww is offline   Reply With Quote
Old 03-06-2008, 16:07   #6 (permalink)
Registered User
 
Join Date: Jan 2008
Posts: 4
Re: 94 Aerostar bad idle

Hope someone out there can help. To date, replaced plugs and wires. Cleaned throttle plate (twice), replaced idle air control valve solenoid. Idle is still rough sometimes. Also noticed an idle up/down when standing still running in park, engine warm. Kind of like a switch back and forth from cold idle to warm idle. I have a feeling it's a timing adjustment. Also is there any reason to suspect the distributor cap and spindle needs replaced? Any information would be greatly appreciated.
paulwwww is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 21:16.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.