'94 T-Bird Startup Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-07-2007, 17:08   #1 (permalink)
'94 Thunderbird
 
Wafflechunk's Avatar
 
Join Date: Mar 2007
Location: Columbus, Ohio
Posts: 10
'94 T-Bird Startup Problems

Just today I've had some issues with getting my good ol 94 T-bird started up. The first couple times it sounded like the starter was struggling to crank the engine, and now I'm lucky if it will start at all. When I turn the key I can hear like a light buzz coming from the front of the car that lasts a couple seconds and then I get a light click. When it first started happening I assumed the battery because at my last oil change(about 1k miles ago) my batter test said that it needed to be replaced soon, so I replaced the battery right away and because of the corrosion I replaced the battery connectors. no change after all that. One thing I do find a bit odd is that if I leave the car alone for maybe 30-60 minutes and then try and start it I have a better chance at getting it going, but it still sounds like it's struggling.

I've been talking with my wife's dad about it and he thinks the only things left that could be the problem is the starter or the solenoid. Is there anything else I should check for?
Wafflechunk is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-09-2007, 13:34   #2 (permalink)
wasnt me
 
390wagon's Avatar
 
Join Date: Oct 2004
Location: new hampshire USA
Age: 31
Posts: 281
Re: '94 T-Bird Startup Problems

check ground connections at the block, frame, and body.
__________________
68 Ford Country Sedan Wagon-390 FE, C6, 9 Inch
87 Chevy Caprice Classic Wagon-307, 2004R, 10 Bolt, what can i say, i grew up with that car
390wagon is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 08:39.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.