ABS Issues. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 01-08-2002, 01:58   #1 (permalink)
exodius
Guest
 
Posts: n/a
ABS Issues.

My abs aint working .. to well at all.

I can brake, and just lock up, but my ABS wont work, i have yet to get it checked a second time, But im just curious has anyone had any problems with their abs on a ef/el falcon before etc?

(check abs light is on, dont pump when u try lock up)
  Reply With Quote
Sponsored Links
Advertisement
 
Old 01-08-2002, 02:14   #2 (permalink)
Bring Back the 24hr!!!
 
Donut King's Avatar
 
Join Date: Feb 2001
Location: Ford - No Victories!
Age: 32
Posts: 5,809
This seems like a good time to plug <a href=http://donutking.fordforums.com/australia/fp.html TARGET="_Blank">australia.fordforums.com</a>

in the tech articles section we have an excellent article perpared by Xyphoid which helps to diagnose ABS problems. It might help, it may not. If it is no use i would take it straight to be checked out by a brake specialist.
Donut King is offline   Reply With Quote
Old 01-08-2002, 02:45   #3 (permalink)
exodius
Guest
 
Posts: n/a
yer thanks man
he already suggested stuff to me

was just curious if people actually have had any problems etc :)

thanks :)
  Reply With Quote
Old 01-08-2002, 03:06   #4 (permalink)
Bring Back the 24hr!!!
 
Donut King's Avatar
 
Join Date: Feb 2001
Location: Ford - No Victories!
Age: 32
Posts: 5,809
Quote:
Originally posted by exodius
yer thanks man
he already suggested stuff to me

was just curious if people actually have had any problems etc :)

thanks :)
Ahh I thought as much, but had to get in a shameless plug for the website which I am developing to complement the forums and raise awareness of it before launch and all that stuff :s5
Donut King is offline   Reply With Quote
Old 01-08-2002, 04:25   #5 (permalink)
Ex Member
 
Fairlane Boy's Avatar
 
Join Date: Nov 2001
Location: Perth
Posts: 717
its happend on my old EF

all it was was a bit of crap blocking one of the sensors...

check em out, maybe thats all it is
Fairlane Boy is offline   Reply With Quote
Old 01-08-2002, 18:02   #6 (permalink)
Australian EB Fairmont Ghia Member
 
eb_5litre's Avatar
 
Join Date: Jun 2001
Location: Newcastle NSW
Posts: 1,151
My ABS works... you can have it too, the piece of shyte.
I absolutely cant stand ABS.... everytime you break and one wheel hits a few stones it cuts in... nearly put me through an intersection once.
ABS should be an option IMO.
__________________
Signatures are for poofs !!

1993 EBII Fairmont Ghia 5.0L Wagon,
Lowered, Tinted, 17" Speedy Ravens & 2.5" Sports Exhaust.
( 1 of 26 built )

AND

1985 Telstar TX5 Turbo, stock as a rock.
eb_5litre is offline   Reply With Quote
Old 01-09-2002, 00:14   #7 (permalink)
Australian XR8 Member
 
Join Date: Jul 2001
Location: Wellington, NZ
Posts: 170
Quote:
Originally posted by DONUT KING
This seems like a good time to plug <a href=http://donutking.fordforums.com/australia/fp.html TARGET="_Blank">australia.fordforums.com</a>

in the tech articles section we have an excellent article perpared by Xyphoid which helps to diagnose ABS problems. It might help, it may not. If it is no use i would take it straight to be checked out by a brake specialist.
SH*T - someone stole the rotors off the TE50. Talk about disconnection of ABS!
__________________
AUIII XR8, Manual. Herrod Motorsport bits
AUII XR8 is offline   Reply With Quote
Old 01-09-2002, 01:19   #8 (permalink)
Aussie Falcon Enthusiast
 
Join Date: Feb 2001
Location: Sydney, NSW, Australia
Posts: 478
eb_5litre

I know exactly what you mean. Same in my ED. Its because the ABS in pre EF Falcons is a dodgy Bendix job that is slow cycling and generally poor. These days I am very careful not to have to brake hard when coming to an intersection where the road just before is bumpy. The adrenalin certainly rises when the ABS kicks and the car seems to lurch forward as you reach the intersection, hehe.

By comparison the Bosch ABS in the AU1 ESP Falcon I drove was excellent. Of course that car had IRS as well so it handled the bumps much better.
anakha is offline   Reply With Quote
Old 01-09-2002, 01:35   #9 (permalink)
300+rwkw DC LTD Member
 
LTDHO's Avatar
 
Join Date: Jul 2001
Location: Melbourne, Vic
Age: 39
Posts: 1,620
I'm not overly happy with mine either. Is there any upgrades???

Bigger Better??
__________________
LTDHO
Power by Herrod 185rwkw
Power by me 313.6rwkw
Stereo by ///Alpine
LTDHO is offline   Reply With Quote
Old 01-09-2002, 05:35   #10 (permalink)
Aussie Falcon Enthusiast
 
Join Date: Feb 2001
Location: Sydney, NSW, Australia
Posts: 478
LTDHO

Don't think it would be an easy conversion but newer Fords are using a Bosch 5.3 system. I reckon the one to go for would be the 4 channel setup as used in the S1 TS50. Interesting that they dropped it for the 3 channel version in S2 and 3. One of several cost cutting measures I'd say.
anakha is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Idle Issues SiX_iN_a_RoW Inline 6 Tech 16 05-26-2004 09:10
ST170 Issues & Fixes mbye2 Ford SVT Vehicles | SVO Vehicles 4 07-02-2003 14:40
Bulk EA issues... Axeman82 General Tech 6 04-08-2003 05:29
ST170 Issues & Fixes mbye2 Ford SVT Vehicles | SVO Vehicles 0 02-13-2003 06:29

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 06:41.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.