Acceleration problems ... - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-27-2001, 18:02   #1 (permalink)
KING of KEBABS
 
XR8beast's Avatar
 
Join Date: Aug 2001
Location: Sydney
Posts: 64
Acceleration problems ...

hi ppl !
i got an EL2 Xr8 with auto transmission ,here is my problem ! when i punch the pedal to the floor it seems to bogg down and only above 4500 rpm does she kick in. I have fully serviced it new plugs ,oil filter,air filter etc..spark plugs are the correct gap also and i have always used optimax ! any ideas ??
thanx.
XR8beast is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-27-2001, 20:24   #2 (permalink)
Paul
Guest
 
Posts: n/a
Sounds like an auto problem to me.Not kicking down. ????
  Reply With Quote
Old 11-28-2001, 08:24   #3 (permalink)
KING of KEBABS
 
XR8beast's Avatar
 
Join Date: Aug 2001
Location: Sydney
Posts: 64
nah the auto kicks down properly ! sometimes when i shift down into second and accelerate it has a flat spot but it does not do it all the time.It also seems to disappear when the engine is restarted after 10 to 15 minutes , it definatly accelerates harder but only till it warms up again..
XR8beast is offline   Reply With Quote
Old 11-28-2001, 08:35   #4 (permalink)
Registered User
 
Join Date: Aug 2001
Location: Melbourne, Victoria, Australia
Posts: 25
perhaps give the auto a service...change the fluid, keeping the old filter in...take it for a drive...then change it, with the new filter..

worked wonders on mine after i noticed it was becoming a little doughey to accelerate on kick down
roTor is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Jury Finds for Ford in Sudden Acceleration Suit Stacy94PGT Ford Worldwide News 0 03-06-2003 20:12
Ford's experiences problems with new diesel; 6.0 Power Stroke is important test Stacy94PGT Diesel Tech 0 03-04-2003 05:32
Quality problems bedevil Jaguar's X-Type Stacy94PGT Ford Worldwide News 1 05-29-2002 21:19
Ford blames its suppliers for quality problems, demands improvement Stacy94PGT Ford Worldwide News 0 05-28-2002 08:58

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 14:43.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.