Alternators - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 5 (permalink) Old 10-26-02, 04:01 PM Thread Starter
Formerly EAII_Fairmont
 
AUII_Forte's Avatar
 
Join Date: Aug 2002
Location: Dubbo NSW
Age: 31
Posts: 917
Alternators

My alternator has just died on me.....for what reason I don't know! It was working fine at 10pm last night, get in it this morning and the battery light stayed on and the alarm went off. I got out and checked the belt, all seemed good. Went for a drive and the light went out. when I got in it again it just stayed on. I've checked all the connections, the battery is fine (not for long if i don't find out whats up), the alternator is not making any strange noises. Do they just die like that??? What I want to know is, did the EA receive a new alternator or were they just carried over from the X series? I preferably want to get a second hand one, but new if I find one at the right price. How much am I looking at?

AUII_Forte is offline  
Sponsored Links
Advertisement
 
post #2 of 5 (permalink) Old 10-26-02, 05:29 PM Thread Starter
Formerly EAII_Fairmont
 
AUII_Forte's Avatar
 
Join Date: Aug 2002
Location: Dubbo NSW
Age: 31
Posts: 917
I just thought of how I might have killed it! I washed and degreased the engine bay yesterday, but I put a plastic bag over the alternator just for safety. It still got a little bit in it, but not a lot. This happened in the morning and the car was fine all day, so I don't know if this is the culprit or not. Would water have a huge effect on the alternator anyway? Judging from the position of it, it'd quite easily cop a bit of water from underneath on a wet day.

1992 AXII Telstar TX5 Ghia

121kW 2.5L DOHC V6 in a car that weighs 1100kg's and looks like a 4 banger from the outside......SLEEPER!

1988 EA S Pak 3spd CFI.....Soon to be a 250rwkw HSV eating machine.
Latest update......MPFI!!
AUII_Forte is offline  
post #3 of 5 (permalink) Old 10-26-02, 06:19 PM
EB wagon
 
Join Date: May 2002
Location: 8 Mile Plains, Brisbane
Posts: 932
Hey dude.... My alternator died the otherday aswell.... I was stuck on the side of the road... called the RACQ and he did all those tests and said the alternator was putting out a voltage but wasnt putting out enuf to keep the batterey charged. Was due to a faulty regulator. He reckons it was coz it was covered in oil from my leakin power steerin pump. Anyway - i didnt have the money for a new or reconed unit so i picked one up from the wrecker for $40. (Sorta good coz they come with a 90 day exchange policy so if it ****s up - ya get another one) Im not sure about the XF alternators on an EA.... What i do know is the XF alternator had a different style pulley from my EB. I ended up using a Telstar unit on my EB.

Brent

EB1 3.9L MPI Falcon Wagon with converted T5 / Pacemaker & 2.5" Redback sports exhaust / 2" lowered blocks at the rear, Kings lows up front / ED Tickford Head and Cam / K&N panel filter with XH intake Snorkel / Full EL Fairmont interior with woodgrain

89 EA1 3.9L TBI Falcon Sedan with 3 speed auto / currently being upgraded...
Brent79 is offline  
post #4 of 5 (permalink) Old 10-26-02, 08:48 PM Thread Starter
Formerly EAII_Fairmont
 
AUII_Forte's Avatar
 
Join Date: Aug 2002
Location: Dubbo NSW
Age: 31
Posts: 917
I think I found a good deal at Supercheap auto. $199 for a genuine Bosch highout put job, like the ones in police cars. I whacked it in and it's as good as new. :)

1992 AXII Telstar TX5 Ghia

121kW 2.5L DOHC V6 in a car that weighs 1100kg's and looks like a 4 banger from the outside......SLEEPER!

1988 EA S Pak 3spd CFI.....Soon to be a 250rwkw HSV eating machine.
Latest update......MPFI!!
AUII_Forte is offline  
post #5 of 5 (permalink) Old 10-27-02, 03:14 PM
-
 
Join Date: May 2002
Location: Melbourne, Victoria
Age: 35
Posts: 1,675
how many amps is a high output model?
standard is 85A.

Jase

T.I. Performance - Performance Tuning for your Ford. J3 Chips, DIY Tuning Kits, Wideband O2 Controllers and much more!
galapogos01 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Alternators svo347 General Tech 6 11-15-02 09:31 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome