BA FPV GT-P Performance issue?? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 02-21-07, 03:00 AM Thread Starter
Registered User
Join Date: Dec 2004
Age: 46
Posts: 85
BA FPV GT-P Performance issue??

Hi Guys/Girls,

I recently purchased a 2003 BA FPV GT-P with 40,000kms on the clock.
When cold the car appeared to have a flat or "Dead spot" in the accelerator, which i then found to go when hot (you know the type that you had when carbys were around) as well as when warm if you pull away from the lights under full acceleration or out of a corner etc the car "Bogs down" and seems to think about going and after a few seconds it actually does go- very hard.
I have had a "Carbon clean" through the injectors/ engine and also had the throttle body cleaned out and this has helped a little however the "bogging down" issue is still with the car, any help would be appreciated??
Fordaus01 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome