Bit of a weird one...? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 09-25-03, 03:25 AM Thread Starter
Shaken Not Stirred
 
the_scotsman's Avatar
 
Join Date: May 2002
Location: Nowra, NSW
Age: 35
Posts: 328
frown Bit of a weird one...?

I had a small leak in the water hose that runs to the heater core. I found this as the "low water" light came on...EF Fairmont Ghia btw.
I flushed out the water system and refilled etc...
Now the "low water" light doesnt seem to want to go off. I woud normally assume the float has busted or crumbled due to age, just like me EA did. BUT, the light doesnt come on with the ignition, and only comes on about 30 seconds after starting the engine. Wouldnt it come on straight away if it was a fault with the float or sensor. The water level is DEFINATELY ok. ANy ideas? IS it just a knackered float/sensor?

Cheers!
the_scotsman is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 09-25-03, 04:02 AM
Green's Tuff!
 
Heritage's Avatar
 
Join Date: Mar 2003
Location: Wonthaggi, Victoria
Age: 42
Posts: 802
Re: Bit of a weird one...?

Try bleeding the system of air, and topping it up with water.
Heritage is offline  
post #3 of 4 (permalink) Old 09-25-03, 05:04 AM Thread Starter
Shaken Not Stirred
 
the_scotsman's Avatar
 
Join Date: May 2002
Location: Nowra, NSW
Age: 35
Posts: 328
What is the proper way to bleed the system. I usually just bring the car up to normal temp, turn the climate control up full temp and take the cap off the tank...is this the correct way?

Cheers
the_scotsman is offline  
post #4 of 4 (permalink) Old 09-25-03, 03:40 PM
Green's Tuff!
 
Heritage's Avatar
 
Join Date: Mar 2003
Location: Wonthaggi, Victoria
Age: 42
Posts: 802
Re: Bit of a weird one...?

Have a look at the thermostst housing and see if there is a bleeder nipple, if there is, just remove the radiator cap,start the car and back the nipple off a bit, when you get a steady stream of water coming out tighten it up.
Heritage is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Weird mechanical problem, help please? jjj Australian Falcons 12 03-25-03 01:39 AM
Weird vibration from auto trans in an EL Wazza80-99 Trans | Driveline 5 09-23-02 02:22 AM
My EF Falcon making weird noise SimonH General Tech 7 02-13-02 11:19 PM
Weird sound from behind my EF Pearly General Tech 11 02-02-02 03:36 AM
My weird dream. Space Lord The Pub 5 09-29-01 10:13 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome