car dies when put in drive - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 07-11-06, 05:20 PM Thread Starter
Registered User
 
Join Date: Apr 2006
Posts: 3
confused car dies when put in drive

Hi i am restoring a 1965 ford galaxie 500 with a 427 engine and automatic trans.it starts right up and idles fine but when i put it in drive or reverse and hit the gas the car will move a little then die. I am not sure what it could be because i recently put a new 770 holley carb in it along with a new fuel pump,changed all the fuel filters put fresh spark plugs in, new selonoid and coil changed the oil added tranny fluid and even redid the gas tank. If anyone has any suggestions it will be greatly appreciated. THANKS!!!

MR.N is offline  
Sponsored Links
Advertisement
 
post #2 of 2 (permalink) Old 07-11-06, 09:43 PM
New toy in the shed
 
Join Date: Aug 2004
Posts: 563
Re: car dies when put in drive

Did you cheak the rev's at idle and then in drive. You may find it is as simple as adjusting the idle to bring it up a bit.
ch7472 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome