cat coverter problem? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-23-04, 04:53 AM Thread Starter
SlAmMeD_fAlCon's Avatar
Join Date: Aug 2003
Location: Wodonga, Victoria
Age: 31
Posts: 72
cat coverter problem?

Hey guys,

How can you tell if your cat converter has had it? My car is running like a dog, lost power and the exhaust note has changed...its more tiny and not as deep and drony if that makes sense. On start up the exhaust is always putt putty until it warms up and then goes away. How can i tell if it could be the problem?

SlAmMeD_fAlCon is offline  
Sponsored Links
post #2 of 3 (permalink) Old 11-23-04, 04:55 AM
Veteran Ford Member
Join Date: Jan 2003
Location: Melbourne, Australia
Age: 30
Posts: 5,083
Re: cat coverter problem?

Give it a smack or two from underneath and see if it rattles, that's a dead give away. Otherwise take it off and have a look inside it.
psycho chicken is offline  
post #3 of 3 (permalink) Old 11-23-04, 06:07 PM
Sik EA bro
Join Date: Jan 2004
Posts: 732
Re: cat coverter problem?

u will hear it 1stly ! lol sounds shokin

aussie aussie aussie OI OI OI!
p4r4l3l is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Ford Escape liftgate problem and steering column problem macollin Ford Escape | C-MAX | Mercury Mariner Forum 0 09-23-04 08:27 AM
87 Bronco-Fusible link problem, maybe? HELP ladyferricher Ford Bronco Forum 1 09-14-04 10:16 PM
Steering/wheel alignment problem mike98AUXR6VCT Suspension | Wheels&Tires | Brakes 10 04-23-04 05:33 AM
Need Advice about idle problem after timing job... pgt96w99k V6 and Hot4 Tech 0 08-02-03 03:45 PM
EF Wiper problem Darren.Parish General Tech 5 03-19-02 07:35 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome