CFI idle problem fixed - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 05-13-2002, 13:20   #1 (permalink)
jezza
Guest
 
Posts: n/a
CFI idle problem fixed

For anyone with weird idle speed problems, I finally fixed my EA by bridging the power steering pressure switch (obviously busted)... drives like a dream now (replaced the EGO and injectors as well)

thanks guys, the tow car lives again :-)
  Reply With Quote
Sponsored Links
Advertisement
 
Old 05-13-2002, 16:56   #2 (permalink)
Registered User
 
Join Date: May 2002
Location: Sydney, AUS
Posts: 44
Also check for loose earth connections

The whole fiasco with my wagon today started because I had idle and stalling problems. I started with a cleaning of the battery terminals and the necessary "computer relearn", but found that my main earth connection on the engine block mount was loose and playing voltage havocs. In the process I knocked some wiring and the car would not budge for about 3 hours of head scratching. But after driving for a couple hours this afternoon, she runs a sweet as can be.

So there is another culprit for lousy idling,

Lynn
89EAwagon is offline   Reply With Quote
Old 05-19-2002, 16:53   #3 (permalink)
rambo
Guest
 
Posts: n/a
idling problems

Guys,

Can someone help me with this surging idle of my
11/89 EA, as soon as you put the gear to PARK..i.e.
ready to turn the ignition off ?

Some comments said something about Throttle
Body Switch ? I'm a 1st timer with Ford and would
appreciate any help.
  Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EA CFI 3sp auto (1989): Problem with idle return sambulance Inline 6 Tech 4 08-09-2003 04:06
Valve stem seals and Idle problem EA1191 General Tech 1 01-16-2003 03:58
EBII Idle Problem XR6000 General Tech 3 01-14-2003 23:29
Base Idle Problem Kwigibo General Tech 4 05-06-2002 01:43
EL FORD XR6 ROUGH IDLE PROBLEM Jason Smith Inline 6 Tech 28 04-06-2001 22:20

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 23:50.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.