check engine light ????? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-17-2005, 07:07   #1 (permalink)
Registered User
 
Join Date: Apr 2005
Posts: 16
confused check engine light ?????

ran my 96 t-bird lx 4.6l low on oil (gauge inside car said it was fine) never trust your gauges! any way i had the oil and filter changed, light stays on. is this normal? will i have to take it to mechanic to have them reset it, im unfamiliar with this car. thanks
randynester is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-17-2005, 11:20   #2 (permalink)
***** Idiot....
 
LunaticSVT's Avatar
 
Join Date: Feb 2001
Location: The Sticks of Central TX
Posts: 10,561
Re: check engine light ?????

By light do you mean the CEL or the Oil indicator light?

If it is the CEL then you can remove the positive battery terminal for 30 minutes to clear it. Want to say it was 15minutes, but for some reason 30 minutes is standing out in my head.

If it is the oil light there may be an issue with the sensor itself. Something you will want to have the mech look at.
LunaticSVT is offline   Reply With Quote
Old 04-17-2005, 15:42   #3 (permalink)
Registered User
 
Join Date: Apr 2005
Posts: 16
biggrin Re: check engine light ?????

worked, thanks lunaticsvt
randynester is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 07:07.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.