Cltuch help needed!! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 04-15-2002, 06:01   #1 (permalink)
Registered User
 
Kypez's Avatar
 
Join Date: Sep 2001
Location: Sydney, Australia
Posts: 518
Question Cltuch help needed!!

G'day guys,

small problem... but I have no clue... how do I fix a new clutch cable in...?? I did it once on my 6 cylinder... but its seems different on the v8... all the same... can someone tell me how to fix a new clutch cable on a ED V8....

Cheers.
__________________
Quiet... They are sleeping
BA XR8 Manual, BluePrint, Momo Steering, Momo Shifter, Leather, Sunroof, Premium Sound, Premium Brakes, 20" X 8.5" HP Hekitk Wheels. Herrod Lowering Springs and Chip, Brad Garlic Reprogramme, NO REAR SPOILER.
Kawasaki ZX 10R, Lime Green. 0-100kms/hr 2.8 sec, 0-160kms/hr in under 5.5 sec. 0-400m 9.4 sec. First gear sees you to 185kms/hr. THE CHAMP IS HERE!
Kypez is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 04-15-2002, 07:31   #2 (permalink)
Registered User
 
Join Date: Mar 2002
Location: Liverpool , Sydney
Posts: 212
Re:Clutch Cable

If you dont have one,get a workshop manual and if you have a little mechanical knowledge it shouldnt be too hard. I myself have never worked on an ED V8 but I would imagine it would be pretty straight forward. Youll never never know if you never have a go.
Great White is offline   Reply With Quote
Old 04-15-2002, 09:30   #3 (permalink)
Registered User
 
Kypez's Avatar
 
Join Date: Sep 2001
Location: Sydney, Australia
Posts: 518
I'm just having trouble taking the box off the gearbox... the one that the clutch attaches to... got the rest off... any ideas?
__________________
Quiet... They are sleeping
BA XR8 Manual, BluePrint, Momo Steering, Momo Shifter, Leather, Sunroof, Premium Sound, Premium Brakes, 20" X 8.5" HP Hekitk Wheels. Herrod Lowering Springs and Chip, Brad Garlic Reprogramme, NO REAR SPOILER.
Kawasaki ZX 10R, Lime Green. 0-100kms/hr 2.8 sec, 0-160kms/hr in under 5.5 sec. 0-400m 9.4 sec. First gear sees you to 185kms/hr. THE CHAMP IS HERE!
Kypez is offline   Reply With Quote
Old 04-15-2002, 17:15   #4 (permalink)
Shh i'm huntin more power
 
Jase_ELXR8's Avatar
 
Join Date: Jul 2001
Location: Melbourne
Posts: 1,764
they have two spastic metal tabs that sit inside the bellhousing. Pull the cover back, push up and pull out... Very stupid idea IMHO...
Jase_ELXR8 is offline   Reply With Quote
Old 04-16-2002, 06:46   #5 (permalink)
Registered User
 
Kypez's Avatar
 
Join Date: Sep 2001
Location: Sydney, Australia
Posts: 518
Thanks!!

I figured it out this afternoon... took me a whole 15 minutes to connect everything up... feel like a goose!

Thanks again...
__________________
Quiet... They are sleeping
BA XR8 Manual, BluePrint, Momo Steering, Momo Shifter, Leather, Sunroof, Premium Sound, Premium Brakes, 20" X 8.5" HP Hekitk Wheels. Herrod Lowering Springs and Chip, Brad Garlic Reprogramme, NO REAR SPOILER.
Kawasaki ZX 10R, Lime Green. 0-100kms/hr 2.8 sec, 0-160kms/hr in under 5.5 sec. 0-400m 9.4 sec. First gear sees you to 185kms/hr. THE CHAMP IS HERE!
Kypez is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Advice needed - fuel efficiency, oils, mods vvsingh General Tech 8 03-02-2003 18:03
Desol valve is it needed EA90_S General Tech 0 01-20-2003 03:25
carby help needed rastan General Tech 3 12-22-2002 00:55
Information needed...(strobe lights?) AlbertM The Pub 11 04-20-2002 01:35
Over fueling ea spac 5sp mpi Excorsism needed. jsantas Trans | Driveline 4 03-24-2002 11:34

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 18:41.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.