Could it be the plugs & leads - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 11-22-04, 01:52 AM Thread Starter
E Series Chick Supremo
 
Mother Nature's Avatar
 
Join Date: Sep 2001
Location: MBFNW
Age: 49
Posts: 2,072
Could it be the plugs & leads

Hey guys,

We have just got back from Sydney and have found a slight problem that I would love to figure out before it gets to the old EA fuel pump proportions.......

As this is a private forum I will state approximate speeds

When doing around 120 (on a private road of course ) downhill there seems to be a bit of a miss, its almost unnoticable but I can feel it. I also have found when I try to accelerate she seems to not want to go anywhere & then takes off as if nothing is wrong ......

Could it be as simple as leads & plugs or am I destined to have cars that baffle the crap out of us all ??????

Apart from that she is going great & the fuel economy is a dream ... this doesnt seem to happen when traveling at so called normal speeds .....


:fairy


94 ED XR8 Sprint


Check out the OzECruisers Inc. website HERE

FF Lynch Mob BITCH
O.F.R #65
Mother Nature is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 11-22-04, 04:17 AM
Experimental Racer#6
 
TIKFD6's Avatar
 
Join Date: Nov 2000
Location: Wodonga Vic
Age: 43
Posts: 8,204
Re: Could it be the plugs & leads

Do all the normal check Lisa, leads for contunuity, plug condition.
How far is the car from its next service?
TIKFD6 is offline  
post #3 of 8 (permalink) Old 11-22-04, 05:16 AM
Jim Mock You Rock
 
Join Date: Jul 2004
Location: sYDNEY
Age: 47
Posts: 1,766
Re: Could it be the plugs & leads

Sounds like a fuel block somewhere....Maybe a fuel filter???
useless is offline  
post #4 of 8 (permalink) Old 11-22-04, 11:50 PM Thread Starter
E Series Chick Supremo
 
Mother Nature's Avatar
 
Join Date: Sep 2001
Location: MBFNW
Age: 49
Posts: 2,072
Re: Could it be the plugs & leads

Ive done over 15k in her so far since the middle of August & havent had the time to do a service as yet ........I know, I know she needs one badly .......


Useless ...... I was thinking the same thing but hopiing not fuel ..... Ive had enough of fuel type issues lately :s


:fairy

94 ED XR8 Sprint


Check out the OzECruisers Inc. website HERE

FF Lynch Mob BITCH
O.F.R #65
Mother Nature is offline  
post #5 of 8 (permalink) Old 11-23-04, 02:21 AM
Experimental Racer#6
 
TIKFD6's Avatar
 
Join Date: Nov 2000
Location: Wodonga Vic
Age: 43
Posts: 8,204
Re: Could it be the plugs & leads

i dont really think its fuel, unless its when your flooring it.
TIKFD6 is offline  
post #6 of 8 (permalink) Old 11-23-04, 02:32 AM Thread Starter
E Series Chick Supremo
 
Mother Nature's Avatar
 
Join Date: Sep 2001
Location: MBFNW
Age: 49
Posts: 2,072
Re: Could it be the plugs & leads

Kerry ... Im not flooring it .... not when the misses seem to happen ... thats just normal driving out here ....

When it seems to not go anywhere from stop, lets say at those stupid red,orange & green thinggys ........ she just seems to sit still no matter what acceleration is applied & then takes off like normal after a few seconds .... which I will add seems like an eternity when sitting up against a car ... hahahhaha nah seriously ..... its a pain in the bum & I think its realted to the higher speed thinggy ......


:fairy

94 ED XR8 Sprint


Check out the OzECruisers Inc. website HERE

FF Lynch Mob BITCH
O.F.R #65
Mother Nature is offline  
post #7 of 8 (permalink) Old 11-23-04, 04:11 AM
Experimental Racer#6
 
TIKFD6's Avatar
 
Join Date: Nov 2000
Location: Wodonga Vic
Age: 43
Posts: 8,204
Re: Could it be the plugs & leads

When was the last time your auto was serviced?
it may be a slipping?
TIKFD6 is offline  
post #8 of 8 (permalink) Old 11-23-04, 04:49 AM
Registered User
 
dpk83's Avatar
 
Join Date: Apr 2003
Location: Melbourne
Age: 32
Posts: 1,175
Re: Could it be the plugs & leads

also, a simple check would be your throtle cable. You never know Good luck MN. :)
dpk83 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Leads, Plugs, Air Filter? Menco Inline 6 Tech 6 08-17-04 07:23 AM
EF Spark Plugs and Leads RedEF6 Inline 6 Tech 12 08-14-04 06:57 AM
New leads, plugs, cleaned radiator juarez Australian Falcons 6 01-05-04 04:16 AM
5.0 Missing after plugs and leads change NZ Windsor Tech 2 12-03-03 10:45 PM
xr6 plugs leads??? AU1SIXA Inline 6 Tech 10 03-25-02 04:50 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome