door lock/latch problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 10-04-04, 11:37 AM Thread Starter
Registered User
Join Date: Oct 2004
Age: 43
Posts: 2
door lock/latch problem

Hello, everyone.

I have a '94 F-150 with a couple of very irritating problems, both of them door related.

My passenger side door can only be opened from the inside. This problem started a few months ago. Also, both doors cannot be locked, from the inside or outside.

I pulled the door panels and lubed everything up. Also I checked all the linkage. It all seems fine, it's the same on both sides. On the drivers side (which opens from the inside or out) when I have the door open and I manually snap the catches into the closed position I can either (1) get them to unlatch/release from inside or out by simply pulling the lever(inside) or operating the button (from outside) or (2) get it to release by sticking a pencil into the latch area and pushing on the center of the latches. I hope that makes sense.

On the passenger side the only way to release the latches is pulling the handle from the inside. The outside button or the pencil trick does not work.

Like I said, I don't believe any linkage is detached and on both doors the linkage moves in the same fashion.

Any ideas??
MikeP is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Ford Escape liftgate problem and steering column problem macollin Ford Escape | C-MAX | Mercury Mariner Forum 0 09-23-04 08:27 AM
87 Bronco-Fusible link problem, maybe? HELP ladyferricher Ford Bronco Forum 1 09-14-04 10:16 PM
Steering/wheel alignment problem mike98AUXR6VCT Suspension | Wheels&Tires | Brakes 10 04-23-04 05:33 AM
Need Advice about idle problem after timing job... pgt96w99k V6 and Hot4 Tech 0 08-02-03 03:45 PM
EF Wiper problem Darren.Parish General Tech 5 03-19-02 07:35 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome