door lock/latch problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
¬Ľ Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 10-04-2004, 10:37   #1 (permalink)
Registered User
 
Join Date: Oct 2004
Age: 42
Posts: 2
door lock/latch problem

Hello, everyone.

I have a '94 F-150 with a couple of very irritating problems, both of them door related.

My passenger side door can only be opened from the inside. This problem started a few months ago. Also, both doors cannot be locked, from the inside or outside.

I pulled the door panels and lubed everything up. Also I checked all the linkage. It all seems fine, it's the same on both sides. On the drivers side (which opens from the inside or out) when I have the door open and I manually snap the catches into the closed position I can either (1) get them to unlatch/release from inside or out by simply pulling the lever(inside) or operating the button (from outside) or (2) get it to release by sticking a pencil into the latch area and pushing on the center of the latches. I hope that makes sense.

On the passenger side the only way to release the latches is pulling the handle from the inside. The outside button or the pencil trick does not work.

Like I said, I don't believe any linkage is detached and on both doors the linkage moves in the same fashion.

Any ideas??
MikeP is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
2004 Ford Escape liftgate problem and steering column problem macollin Ford Escape | C-MAX | Mercury Mariner Forum 0 09-23-2004 07:27
87 Bronco-Fusible link problem, maybe? HELP ladyferricher Ford Bronco Forum 1 09-14-2004 21:16
Steering/wheel alignment problem mike98AUXR6VCT Suspension | Wheels&Tires | Brakes 10 04-23-2004 04:33
Need Advice about idle problem after timing job... pgt96w99k V6 and Hot4 Tech 0 08-02-2003 14:45
EF Wiper problem Darren.Parish General Tech 5 03-19-2002 18:35

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 16:20.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.