EA help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-01-2002, 21:52   #1 (permalink)
Registered User
 
Join Date: Jul 2002
Location: Canberra
Posts: 64
mad EA help

I am outta ideas on this EA... Decided to come ask you guys...
I asked the same thing on the EA discussion board about 10 times but done a bit to it since...

Ok... The car idles fine, and runs fine up till about 3000 rpm... Once it gets over 3000 rpm it misfires completely...

Checked/Replaced

Electrical -
Spark Plugs, Leads, Ignition Coil, Battery, Distributor, Computer (ALL GOOD)

Sensors -
Coolant Temp, MAP Sensor (ALL GOOD)

Fuel System -
Fuel Pump, Fuel Tank, Fuel Pressure Test, Injectors, Filter (ALL GOOD)

Anyway... any ideas on this would be appreciated.
daihat is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 07-01-2002, 21:57   #2 (permalink)
400 kg ego
 
Troutman's Avatar
 
Join Date: Apr 2002
Location: Melbourne
Posts: 6,188
Welcome back mate! To link your old and new usernames, visit:

http://discussions.fordforums.com/sh...7&pagenumber=1

I'm confident you'll get a better response here than on our old board.
__________________
Jack Travis, E-Series Acting President

1989 Ford Fairmont Ghia turbo/GL replica (underway)
1994 Eunos 800M
1990 Ford Laser S
Troutman is offline   Reply With Quote
Old 07-02-2002, 03:31   #3 (permalink)
Australian Falcon Member
 
Join Date: Jun 2001
Location: Western Australia
Posts: 865
This is gonna sound really silly - but is the timing correct? I don't ask that because I underestimate you, it's just that I had that happen to me some time ago - ie. the timing was waay out, which meant that the car ran ok until under load (which in normal driving will generally relate to reaching an rpm point) at which time it went bugshit. That was in an XE tho.
__________________
IT'LL GO OR IT'LL BLOW!!!
EDFUTURA is offline   Reply With Quote
Old 07-02-2002, 06:41   #4 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,816
Checked the TFI module? See http://www.therangerstation.com/TFI_Diagnostic.html
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Old 07-02-2002, 15:42   #5 (permalink)
Registered User
 
Join Date: Jul 2002
Location: Canberra
Posts: 64
EA Help

I have done the timing a few times, and yes, while the diagnostic cable was connected...

Also i have checked the earth on the tfi module, seems to be OK... Had the distributor benchtested too..
daihat is offline   Reply With Quote
Old 07-02-2002, 18:41   #6 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,816
You need to check more than the earth as they fail in all sorts of ways. Backprobe the module with a multimeter as indicated in the link I gave you. If you know some basic electronics they can also be easily repaired using the info on that site.
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EA to ED Falcon review Aussie Falcon The Pub 13 08-24-2004 20:35
XD monts same as EA engine monts ?a 351 into a EA will it go ? Falcon kid General Tech 31 06-21-2004 22:58
EA Advertising Campaigns Sundeep E-Series Falcons 22 04-10-2004 16:45
EA in Wheels' all-time top 10 Falcons. However... Troutman Suspension | Wheels&Tires | Brakes 36 02-22-2004 02:06
MASSIVE CLEAROUT! (Audio, alarms, EA parts) SPHELL Audio And Security 39 05-31-2002 17:17

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 00:59.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.