EA Possessed? please help - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 02-23-03, 05:49 AM
Posts: n/a
EA Possessed? please help


Some advice greatly appreciated. Have an 89 EA 3.9CFI wagon with some odd problems.

1. If I let her just creep away from dead stop it will accelerate albeit slowly to around 40kph. At 12kph itll change to 2nd and at 22kph into top unti I reach 40kph................mmmmmmmmmmm ...........bit strange. It now also appears to be misfiring at idle (feels like a tq20cam as the body starts to rocknroll) and at times idle will go up and then go down, but out on the highway it runs great. Sometimes when I turn her off it will pre-ignite, other times it will not depending whether idle is high or low at the time I stop.

Checked all sensors via ecu and all seem to be working. Did a diag and got no permanent faults.

Engine was remanufactured about 20k ago, so compression and engine internals are fine.

Ok so I adjusted the timing for the hell of it and reset the base idle. No significant change. Noticed that leads were a bit dodgy and no4 plug a bit rich. Assumed that leads and plugs may have been contributing to the problem so changed all leads and plugs but this did not seem to make any real difference.

Any ideas truly appreciated this is drivin me nuts


Sponsored Links
post #2 of 2 (permalink) Old 02-23-03, 05:07 PM
Registered User
Join Date: Dec 2002
Location: Shepparton, Victoria
Age: 33
Posts: 229
I was about to say check No. 4 injector but then felt stupid cause i remembered it was CFI! But check the injectors anyway!

EA Fairmont Ghia : 3.9L MPFI, 2.5" cat back sports exhaust, K&N panel filter. Pioneer head unit, pioneer 4" three way fronts, Pioneer 6" 3 way rears, 2x 12" subs, blue interior light.
My main pride and joy : '76 XB Fairmont GS, 250CI, 140,000 Km and all stock.... for now! (Factory air-con on the way)
SilverEA is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
EA to ED Falcon review Aussie Falcon The Pub 13 08-24-04 09:35 PM
XD monts same as EA engine monts ?a 351 into a EA will it go ? Falcon kid General Tech 31 06-21-04 11:58 PM
EA in Wheels' all-time top 10 Falcons. However... Troutman Suspension | Wheels&Tires | Brakes 36 02-22-04 03:06 AM
EA Possessed? please help wybub E-Series Falcons 4 02-26-03 04:52 AM
MASSIVE CLEAROUT! (Audio, alarms, EA parts) SPHELL Audio And Security 39 05-31-02 06:17 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome