Eb Fairmont Odometer Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 03-17-06, 01:49 AM Thread Starter
Registered User
Join Date: Mar 2006
Posts: 12
Eb Fairmont Odometer Problem

I have an EB Fairmont and the odometer isnt spinning. The KM/H guage works fine. I have checked the electrical connections at the back of the instrument cluster, and it's all good there. Just wondering if anyone else has had this problem, and how is it fixed.
Any help would be much appreciated.
thewan is offline  
Sponsored Links
post #2 of 2 (permalink) Old 03-20-06, 12:34 AM
old B - new B
351cid's Avatar
Join Date: Jul 2005
Location: sunshine coast QLD
Age: 51
Posts: 890
Re: Eb Fairmont Odometer Problem

sounds like the same problem that the xf -> utes had.
i took mine to an instrument repair guy here on the sunshine coast and he fitted a new part, cost about $85 . done in a day.

`75 XB FAIRMONT SEDAN injected 351, toplaoder, disc brake 9", factory paint+ vinyl roof.
`03 BA XLS ute - lpg, auto, lsd, acid rush paint,
351cid is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome