EF Cluster/Auto Problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
¬Ľ Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 11-24-2004, 08:13   #1 (permalink)
wanting 6 gears!
 
Join Date: Mar 2003
Location: Brisbane
Posts: 633
EF Cluster/Auto Problem

We where making up red leds for a friends dash, made 1 it worked. Made 3 more for the tacho,temp,fuel,speed. Anyway one of them blew fried the hole circiut bored to the taco,temp,fuel,speed. Also the dials for those 4 now dont work. All other things on the instrument cluster works, but the cluster smells burnt up the top. From what Iv been told iv fried the board, not good! especially when its a friends car. Im going to try and get a new cluster tomorrow from a wrecking yard.. and idea what I should pay? Will xr/fairmont cluster fit without modification to the wires?

Next problem ok friend goes to drive home no dash lights and the dials arnt working. Doesn't get far comes back says the Auto won't shift out of first gear. I didn't think it would be related to the cluster but its all I can think of. Iv driven it as well tried charging battery so forth but nothing seems to get it out of frist gear.

Any idea's or help on the following issues?

Not been a good day, also paid $40 for led brake lights. Very dull NOT worth it they suck ! Hopefully jaycar take returns.
blinkAU is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 11-24-2004, 08:29   #2 (permalink)
wanting 6 gears!
 
Join Date: Mar 2003
Location: Brisbane
Posts: 633
Re: EF Cluster/Auto Problem

Actually its a 1998 EL Falcon GLI.

I forgot to ask are the EF/EL clusters the same?
blinkAU is offline   Reply With Quote
Old 11-24-2004, 21:03   #3 (permalink)
wanting 6 gears!
 
Join Date: Mar 2003
Location: Brisbane
Posts: 633
Re: EF Cluster/Auto Problem

Fixed. New dash and then turns out a fuse was blown. Don't know if the old dash will still work it smells preety burnt.
blinkAU is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
EF falcon Central Locking problem - Please help fbb2u Interior | Electrical | ECU 3 08-11-2004 03:58
EA CFI starting problem rawlinna Inline 6 Tech 4 06-12-2004 11:10
EF gearbox problem adamvw Trans | Driveline 7 04-14-2003 04:18
EF V8 Ping...(Long) Shark General Tech 30 07-27-2002 14:55
Ford said to fix Expedition problem RPO83 Ford Worldwide News 0 07-09-2002 20:59

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:39.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.