EF-XR6 Oil pressure Gauge Probs - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 6 (permalink) Old 04-23-03, 08:09 PM Thread Starter
Registered User
 
Join Date: Apr 2003
Posts: 6
EF-XR6 Oil pressure Gauge Probs

Hey. I have an EF -XR6 that has a oil pressure gauge prob.The thing shows no pressure complete with warning light and beeps goin off BUT it has no detriment to to way the vehicle is running...no coughs,splutters just smooth going.The oil pressure was tested at the last service and revealed no probs at all..Is anyone aware of any probs with the switch??..The car has 175k's on it.Any help would be great...rgds
buster100 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 (permalink) Old 04-23-03, 08:42 PM
Registered User
 
61sg's Avatar
 
Join Date: Jul 2002
Location: WA
Age: 36
Posts: 701
yeah it pretty common for the switch to fail on these.

go to spare parts and get a new switch p/n EF 9D290 A and that should solve your problems.
61sg is offline  
post #3 of 6 (permalink) Old 04-24-03, 12:46 AM
Ford Member
 
Join Date: Sep 2002
Location: adelaide
Posts: 179
make sure you use a genuine ford one as they have a rubber seal im told. also dont use thread tape as it needs the best earth possable. It earths through the block...
rabbi is offline  
post #4 of 6 (permalink) Old 04-24-03, 04:03 AM Thread Starter
Registered User
 
Join Date: Apr 2003
Posts: 6
oil gauge probs

thanks guys,much appreciated...
buster100 is offline  
post #5 of 6 (permalink) Old 04-27-03, 06:24 AM
removed as previously discussed!
 
Join Date: Mar 2002
Location: NSW
Posts: 675
switch is $50

got a new one
same deal happens.. bloody annoying

:: Australian Ford Falcon Modifications ::
Tech Articles, Modifications and Forums for EA, EB, ED, EF, EL, AU and now BA Falcons!
fUSiON is offline  
post #6 of 6 (permalink) Old 04-27-03, 08:19 PM
Registered User
 
Join Date: Nov 2002
Posts: 13
What grade of oil are you running?

I had much the same problem in my EF2 fairmont, when the place where I had it serviced skimped on the oil quality.

Try changing to a 50 weight oil (synthetic or semi-synthetic) - it worked for me!
stretch2002 is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Oil pressure sender units uteman General Tech 9 05-07-05 04:21 AM
Oil pressure gauge in AU XR6 pegged! Casper General Tech 3 06-06-03 08:28 PM
oil pressure loss bigblockcoupe Ford Mustang Forum 2 09-10-02 11:09 AM
broken oil pressure gauge on ef ghia? trev General Tech 1 09-06-02 08:03 AM
Regular Oil Pressure Gauge Position Styles General Tech 13 08-05-02 03:46 PM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome