electric speedo problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-10-06, 10:13 AM Thread Starter
Registered User
Join Date: Mar 2006
Posts: 2
confused electric speedo problem

i live at norfolk england and can anyone out there help me with this

i have a iveco daily 35/10 1997 .and the speedo has stoped working .have been told it could be one of three things .
the speedo itself .or the sender thats on the gearbox. or there is a box thats in where the fuses are .
now i know what the sender is thats on the gearbox .but what does the box thing look like thats near the fuses so i can identifie it .as there are about 8 little box things in the fuse compartment.i was going to buy a speedo but will try the sender first then if i can find out what the box thing is will get one of them and see before buying the speedo .hope someone can help me with this problem
barrie@kebbell is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome