Engine surges/stalls - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 19 (permalink) Old 02-06-03, 09:08 PM
Posts: n/a
mad Engine surges/stalls

Can anyone help me please.

91 EB falcon series 1.
The engine surges while driving at low speed and stalls when I stop. Have replaced oxy sensor, fuel filter, reset computer and has been to several garages with no luck. Vehicle is almost undriveable.

Recently has had head done, a/c, radiator
Sponsored Links
post #2 of 19 (permalink) Old 02-07-03, 12:15 AM
Formerly EAII_Fairmont
AUII_Forte's Avatar
Join Date: Aug 2002
Location: Dubbo NSW
Age: 31
Posts: 917
Sounds like it could be you MAP sensor. It's a little black thing on the right hand side of the firewall with wires and a vacuum line attached. Check the connections and see if it helps, if not, try and get a hold of one and swap it over and see if it fixes the problem.

1992 AXII Telstar TX5 Ghia

121kW 2.5L DOHC V6 in a car that weighs 1100kg's and looks like a 4 banger from the outside......SLEEPER!

1988 EA S Pak 3spd CFI.....Soon to be a 250rwkw HSV eating machine.
Latest update......MPFI!!
AUII_Forte is offline  
post #3 of 19 (permalink) Old 02-07-03, 12:15 PM
Registered User
Join Date: Sep 2002
Location: 27 00S 153 07E
Posts: 1,944
Have you been using el cheapo petrol? Some of the stuff out there now wouldn't run a tractor!

"I married Miss Right. I just didn't know her first name was Always."
TopGhia is offline  
post #4 of 19 (permalink) Old 02-07-03, 05:46 PM
Posts: n/a

Thanks for the replies.

No the petrol is fine, but I did find the vacuum hose to the map sensor had gone brittle and cracked where it is attached to the inlet manifold. I fixed that and it does seem better, but still not right. I reset the computer and the surging came back although not as bad. I suspect it may need a proper tune up now and more investigation.
post #5 of 19 (permalink) Old 02-07-03, 10:08 PM
Join Date: Mar 2002
Location: Melbourne
Posts: 1,819
Sounds like you might wanna check out the base Idle setting of the car as it could be too low, also the Idle speed controller (located on the throttle body) can give symptoms like this.


Bass Crazy is offline  
post #6 of 19 (permalink) Old 02-07-03, 11:40 PM
Posts: n/a
Is that the screw adjustment near where the throttle cable is attached, because it doesn't seam to be making contact with the throttle mechanism???
post #7 of 19 (permalink) Old 05-09-03, 05:24 AM
Posts: n/a
surging probs

I have a zl fairlane with efi fuel injection with the same problem...turned out to be a leak around one of the injectors...a seel had gone...spray around the injectors with carby cleaner while the car is going and you will soon see if this is the problem..if it is, ford in rockhampton are having a sale on injectors for that model for $39 each ...worth looking at....Wayne
post #8 of 19 (permalink) Old 05-09-03, 08:39 PM
Registered User
Join Date: Jul 2002
Location: Gold Coast
Posts: 55
TPS, almost certainly.


"Daddy, why is Mummy always sitting on that side of the car?"
"Weight distribution, Son."
jr_4226 is offline  
post #9 of 19 (permalink) Old 05-10-03, 01:12 AM
now with EF power!
Join Date: Feb 2003
Location: Rockhampton, QLD
Age: 29
Posts: 891
Sorry, this doesnt have much to do with the post but...

yaramin, do you drive a white zl fairlane with turbo blades?

If you do, i think you pulled up next to me. It was the lights before the old bridge, you were checking out (i think) my turbo blades on my green eb fairmont.

Was that you?



1994 EF Falcon.
(4.0 Auto)

Mods List:
Kenwood head deck, Rockford Fosgate Punch Sub and Punch Amp....and hubcaps!!

My Gallery!
Proud TQE Operator
danege is offline  
post #10 of 19 (permalink) Old 05-11-03, 12:23 AM
Posts: n/a
danege Reply

Yes it was me....nice blades...I need a spare or two...lol
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
Holdens new V6 EED-250 The Pub 52 08-09-03 11:07 PM
Ford Introduces New Duratec Sci Engine With Unique ‘smart Charge Injection’ RPO83 Ford Worldwide News 0 05-14-03 11:59 AM
Ford Motor Company’s 100-millionth V-8 Engine RPO83 Ford Worldwide News 3 04-29-03 08:33 AM
A New Boss Born in Australia RPO83 Ford Worldwide News 0 10-16-02 07:12 PM
BA Falcon Engine Reveal RPO83 Ford Worldwide News 0 09-04-02 08:27 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome