escort lowbeams not working - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 4 (permalink) Old 01-02-07, 06:39 AM Thread Starter
Registered User
 
Join Date: Jan 2007
Posts: 1
escort lowbeams not working

Hello,
Need some advice if anybody has any. I have a 1999 Ford Escort ZX2 and my lowbeams are not working on both headlamps (both quit at same time). I have highbeams, parking lights, fog lights, & interior lights but just no lowbeams. I checked the DRL fuse under the dash and its fine. Could this be due to a bad headlamp relay? Hate to spend the 60 bucks for a new relay if i'm off base. Any input on this would be greatly appreciated. Thanks.

spud28 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 (permalink) Old 01-24-07, 09:24 PM
Registered User
 
Join Date: Jan 2007
Location: Indianapolis
Age: 34
Posts: 6
Re: escort lowbeams not working

I would check your multifunction or headlight switch if i were you.
fiveliterbeatr is offline  
post #3 of 4 (permalink) Old 01-25-07, 04:31 AM
Registered User
 
STUGUTS_XY's Avatar
 
Join Date: Sep 2006
Location: Kalgoorlie W/A
Age: 40
Posts: 34
Re: escort lowbeams not working

check for power with testlight at headlight plug,may be possible blown both filaments in each headlight
STUGUTS_XY is offline  
post #4 of 4 (permalink) Old 01-30-07, 06:15 PM
Registered User
 
Join Date: Jan 2007
Location: Indianapolis
Age: 34
Posts: 6
Re: escort lowbeams not working

it would be highly unlikely that both headlights would go out at once. There should be a cause to it.

fiveliterbeatr is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome