FL-820S Oil Filter - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 2 (permalink) Old 12-26-02, 04:26 PM Thread Starter
Lab Rat
Join Date: Nov 2002
Location: 1500km north of Perth
Age: 55
Posts: 165
roll FL-820S Oil Filter

Just fitted a motorcraft FL-820S oil filter to my 5.4lit V8 (Now Done 1000km).
It cost $32.00 so for that sort of money does the S mean Synthetic or because it shorter then the F9 S is for short?
DavoXT is offline  
Sponsored Links
post #2 of 2 (permalink) Old 12-26-02, 10:09 PM
Registered User
Join Date: Sep 2002
Location: 27 00S 153 07E
Posts: 1,944
It is probably a synthethic micro-glass filter, want to be for the price.

"I married Miss Right. I just didn't know her first name was Always."
TopGhia is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Similar Threads
Thread Thread Starter Forum Replies Last Post
My battle with an oil filter Troutman Australian Falcons 62 11-12-03 05:39 AM
Oil Filter for 5.4lit V8 DavoXT Modular Tech 3 12-16-02 07:14 PM
How to change oil Falchoon The Pub 3 09-29-02 06:57 PM
Oil Filter Cutter TopGhia General Tech 6 09-19-02 02:33 PM
EL Oil & Filter change - now dripping a bit Pseudo General Tech 13 03-22-02 04:02 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome