ford ranger problem - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 3 (permalink) Old 11-27-06, 09:24 AM Thread Starter
Registered User
 
Join Date: Nov 2006
Posts: 2
ford ranger problem

i have a 1993 ford ranger 2wd, 6cyl, auto. when im on level ground the truck runs somewhat ok, but when i start climbing hill it looses all its power. runs like its a 4 cyl. their is no miss in the engene, dosen't want to kick down in trans. i thought that it might be the convertor so i punched it out but no change. it has 112000 miles, check eng light comes on atfer 5 mins of run time. any one have any ideas? thank for any help

hoppnjoe is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-09-06, 07:39 PM
Registered User
 
Join Date: Dec 2006
Location: Phoenix, AZ
Posts: 3
Re: ford ranger problem

how long has it been since the fuel filter has been replaced?
ccs2311 is offline  
post #3 of 3 (permalink) Old 12-11-06, 08:11 AM Thread Starter
Registered User
 
Join Date: Nov 2006
Posts: 2
Re: ford ranger problem

it was changed 2 months ago thanks
hoppnjoe is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome