Gas and high pressure water don't mix.. - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto EscrowInsurance

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 07-22-2002, 03:20   #1 (permalink)
Large Member
 
Fludey's Avatar
 
Join Date: Jul 2002
Location: Melbourne
Age: 36
Posts: 130
Gas and high pressure water don't mix..

Hi all, my first post BTW..
Just got my ED , stuck my EB XR8 rims on, and installed my Kenwood MP3 player , looks absolutely fantastic...

Anyway , took it to the car wash and degreased the engine..

Dont know where the water got in , but now I have very little accel. when on gas , petrols still cool , but gas has no pick-up..

Been 2 days , seems to be on the improve, any ideas what Ive done??

Thanks
Fludey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 08-09-2002, 01:20   #2 (permalink)
400 kg ego
 
Troutman's Avatar
 
Join Date: Apr 2002
Location: Melbourne
Posts: 6,188
Unanswered threads are being returned to the top.
__________________
Jack Travis, E-Series Acting President

1989 Ford Fairmont Ghia turbo/GL replica (underway)
1994 Eunos 800M
1990 Ford Laser S
Troutman is offline   Reply With Quote
Old 08-11-2002, 00:17   #3 (permalink)
Large Member
 
Fludey's Avatar
 
Join Date: Jul 2002
Location: Melbourne
Age: 36
Posts: 130
It's cool now guys , must have dried itself , thanks anyway
Fludey
Fludey is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 01:35.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.