Got my new amp!!! YAY YAY YAY - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 12-23-2002, 03:34   #1 (permalink)
Registered User
 
Join Date: Sep 2001
Location: Perth
Posts: 1,386
Got my new amp!!! YAY YAY YAY

Well, today i bought a new amp for my car. I got the Jaycar 2 x 150wrms amp. Unfortunately its a christmas present, so i have to wait 2(to many) days before I can hook it all up. I'll be using my old xplod sub. And i should be getting my custom box tomorrow aswell. It cost me a carton! Hows that??

Things are finally looking up. I love christmas way too much!!!

Should be KILLA!!!!

I'll let you all know how it sounds when I hook it all up. On the 25th!!

__________________
EL driver...
Futura97 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 12-23-2002, 21:00   #2 (permalink)
Yeah .... I am here
 
XR8fella's Avatar
 
Join Date: Apr 2002
Location: Coffs Harbour NSW
Age: 33
Posts: 751
yeah let us know buddy !!
__________________
His :
Black AU II XR8 Manual Ute
Hers :
XR8fella is offline   Reply With Quote
Old 12-23-2002, 21:04   #3 (permalink)
Registered User
 
Join Date: Jan 2002
Location: Sydney
Posts: 417
Cost you a carton????

Tell me who gave it to you, and ill go and buy a cheap slab for him....

:D
FORDV8 is offline   Reply With Quote
Old 12-23-2002, 21:09   #4 (permalink)
Poor IT guy
 
Homer?'s Avatar
 
Join Date: Jun 2001
Location: Perth WA
Age: 34
Posts: 506
Yeah let us know how it goes.
I should be instaling a 4x100 Jaycar in an XLS soon.

Be carefull 400+wrms might make the Sony live up to it's name and Xpold
Homer? is offline   Reply With Quote
Old 12-25-2002, 04:21   #5 (permalink)
Registered User
 
Join Date: Sep 2001
Location: Perth
Posts: 1,386
geeez... I have a constant ringing in my ears, and my neighbours are p*(&ssed at me!!!

Is that a good enough summary?
__________________
EL driver...
Futura97 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
JL Audio Mono block amp getting too hot EFXR62 Audio And Security 49 11-03-2003 06:47
Amp Problems Thanatos Audio And Security 2 03-06-2003 14:24
Amp and speaker q's z0s0 Audio And Security 2 03-05-2003 15:20
HELP!!: Amp And Sub! PHoeNiX_EB General Tech 4 02-16-2003 06:07
Amp and Sub Issues Timmeh General Tech 4 11-28-2002 00:55

Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 19:57.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.