Help Please Ford Escort 1.6 16v Zetec EFI - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 04-18-07, 03:30 PM Thread Starter
Registered User
Join Date: Apr 2007
Posts: 2
frown Help Please Ford Escort 1.6 16v Zetec EFI

Hi could anyone help me? My wife has a 1997 N reg Escort (uk version) this morning she was on her way to work when the car suddenly died on her. she said it was like the car was about to stall she had her foot on the clutch and it still died. we thought at first that she had ran out of fuel so we put fuel in and still nothing. The engin seems to go to fire but wont start. if you pump the gas pedal it tries but just wont kick in. no engin managment lights have come on and weve checked to see if fuel is being pumped through . has anyone any ideas . the battrey is off tonight to give it some go. before this did happen every now and then it seemed to misfire but then drove ok .
steve_fitz1 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome