Help! Turn signals and Hazards stopped working on 94 Crown Vic?! - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 7 (permalink) Old 11-08-03, 08:15 PM Thread Starter
Registered User
 
Join Date: Nov 2003
Posts: 6
Question Help! Turn signals and Hazards stopped working on 94 Crown Vic?!

It started yesterday morning when the battery was dead..so I jumped started the car, then took it to Walmart for a new battery. However, after the jump start on the way to Walmart, the turn signals, Hazard lights and Some Brake lights stopeed working? I put in a new battery, and the symptoms stayed the same. I checked all fuses by the pedal area and under the hood, and all seemed good. I even replaced the yellow flasher switch under the pedal area , and that didnt work?

Any suggestions or tips? I hope there was no short somewhere..

thnxs,
Francino
94 Crown Victoria LX V8 SOHC

oufyaba is offline  
Sponsored Links
Advertisement
 
post #2 of 7 (permalink) Old 11-08-03, 08:18 PM Thread Starter
Registered User
 
Join Date: Nov 2003
Posts: 6
Re: Help! Turn signals and Hazards stopped working on 94 Crown Vic?!

test if i get replies notices via e-mail?
oufyaba is offline  
post #3 of 7 (permalink) Old 11-08-03, 10:06 PM
Look! A flying orangutan!
 
Join Date: Mar 2003
Location: perth
Age: 33
Posts: 3,104
Re: Help! Turn signals and Hazards stopped working on 94 Crown Vic?!

You've probably missed one of the fuse wires onto the positive terminal of the battery. Depending on the car, many cars will run lights and other high-draw accessories off a couple of fuse wires, in order to reduce the risk of a short causing a wiring fire or draining the battery.

Proud TQE Operator and President of SEFAG - the Society for the Elimination of Ford Automatic Gearboxes

Pacemaker headers + 2.5" exhaust
EF Fairmont interior
MP3 player
Lowered King springs
5 speed manual
EF motor

Newest mod: EF Ghia wiring loom and dash
mongrelEB is offline  
post #4 of 7 (permalink) Old 11-09-03, 10:45 AM Thread Starter
Registered User
 
Join Date: Nov 2003
Posts: 6
Question I checked the positive, and didn;t see any fuses near by?

I checked the positive, and didn;t see any fuses near by?
oufyaba is offline  
post #5 of 7 (permalink) Old 11-09-03, 04:18 PM
Look! A flying orangutan!
 
Join Date: Mar 2003
Location: perth
Age: 33
Posts: 3,104
Re: Help! Turn signals and Hazards stopped working on 94 Crown Vic?!

That's all I can think of, if it has no major fuse wires like that, then I can't help you. Sorry. :(

Proud TQE Operator and President of SEFAG - the Society for the Elimination of Ford Automatic Gearboxes

Pacemaker headers + 2.5" exhaust
EF Fairmont interior
MP3 player
Lowered King springs
5 speed manual
EF motor

Newest mod: EF Ghia wiring loom and dash
mongrelEB is offline  
post #6 of 7 (permalink) Old 11-11-03, 05:26 PM
Registered User
 
Join Date: Nov 2003
Posts: 11
Re: Help! Turn signals and Hazards stopped working on 94 Crown Vic?!

Next is the signal relay inside the fuse box.....After 9 yrs the signal relay gets weak.

You can find them new and cheap at any AutoZone....

they have two types: original and heavy duty.

If u buy the heavy duty one, you may have slight trouble with refit, but they are very good for towing a trailer.

THe slight refit trouble is just a fuse cover issue......the fuse cover may bulge slightly, or not close fully properly.
HandyGuy is offline  
post #7 of 7 (permalink) Old 11-12-03, 04:50 AM
Registered User
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 3,183
Re: Help! Turn signals and Hazards stopped working on 94 Crown Vic?!

fusible links?

Regards Blue
Aussiblue is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help! Turn signals and Hazards stopped working on 94 Crown Vic oufyaba Ford Crown Victoria | Mercury Marauder | Grand Marquis | P71 1 01-11-04 06:43 PM
Help! Turn signals and Hazards stopped working on 94 Crown Vic?! oufyaba Interior | Electrical | ECU 1 11-11-03 05:17 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome