High revving on startup--ED - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

 
LinkBack Thread Tools Display Modes
post #1 of 8 (permalink) Old 05-11-04, 04:02 PM Thread Starter
TQE FAIRMONT GHIA
 
BOON250's Avatar
 
Join Date: Jul 2002
Location: Auckland NZ
Age: 36
Posts: 457
High revving on startup--ED

everytime I start my Ed it revs up to about 1800 before settling down to normal idle. I have reset idle and computer etc any ideas??? This annoys the hell out of me!


1994 Fairmont Ghia ED Built 6/94 4.0 I6 Auto Full Leather Premium Sound Poly Green Clear Indicators AU3 Clear Side Repeaters Lowered Tints "OK LETS ROLL"
BOON250 is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 05-11-04, 05:27 PM
Registered User
 
1LOWEA's Avatar
 
Join Date: Oct 2002
Location: Melbourne
Posts: 434
Re: High revving on startup--ED

I have an EA, and have this problem aswell.

1996 EF Fairmont
17" EL Tickford Wheels
2.5" Redback Exhuast
GL PRO SOUND
www.glprosound.com.au
1LOWEA is offline  
post #3 of 8 (permalink) Old 05-12-04, 06:18 AM
Gonna miss the ED :(
 
EED-250's Avatar
 
Join Date: Oct 2001
Location: Perth, W.A.
Posts: 733
Re: High revving on startup--ED

me 3

1994 ED 6CYL 14.8@92mph
EED-250 is offline  
post #4 of 8 (permalink) Old 05-12-04, 08:20 AM
Registered User
 
Join Date: Nov 2002
Location: Brisbane
Age: 41
Posts: 292
Re: High revving on startup--ED

Over zealous ICS most likely.. taking a while to respond.

Its pretty normal for them to rev to around 1500 for about 1-2secs then settle down near 900 for the warm up cycle.

Gotta remember the motor needs more revs and more fuel to fire cold, and the computer is doing its best to make sure it starts and runs properly when cold.

Try starting an older Falcon with carby without any choke whatsoever and be thankful :)

88 EA Falcon S
3.9litre CFI
5spd Manual

RIP my ol' esky.. many years of good service
eskyboi is offline  
post #5 of 8 (permalink) Old 05-12-04, 10:29 AM
Look! A flying orangutan!
 
Join Date: Mar 2003
Location: perth
Age: 33
Posts: 3,104
Re: High revving on startup--ED

Yeah pretty normal. I wouldn't worry.

Proud TQE Operator and President of SEFAG - the Society for the Elimination of Ford Automatic Gearboxes

Pacemaker headers + 2.5" exhaust
EF Fairmont interior
MP3 player
Lowered King springs
5 speed manual
EF motor

Newest mod: EF Ghia wiring loom and dash
mongrelEB is offline  
post #6 of 8 (permalink) Old 05-14-04, 07:47 PM Thread Starter
TQE FAIRMONT GHIA
 
BOON250's Avatar
 
Join Date: Jul 2002
Location: Auckland NZ
Age: 36
Posts: 457
Re: High revving on startup--ED

Thanks guys.. yeh thank god for fuel injection...

1994 Fairmont Ghia ED Built 6/94 4.0 I6 Auto Full Leather Premium Sound Poly Green Clear Indicators AU3 Clear Side Repeaters Lowered Tints "OK LETS ROLL"
BOON250 is offline  
post #7 of 8 (permalink) Old 05-15-04, 01:14 AM
Registered User
 
1LOWEA's Avatar
 
Join Date: Oct 2002
Location: Melbourne
Posts: 434
Re: High revving on startup--ED

What are the cars suppose to rev at normaly?

1996 EF Fairmont
17" EL Tickford Wheels
2.5" Redback Exhuast
GL PRO SOUND
www.glprosound.com.au
1LOWEA is offline  
post #8 of 8 (permalink) Old 05-15-04, 09:25 AM
Registered User
 
Join Date: Nov 2002
Location: Brisbane
Age: 41
Posts: 292
Re: High revving on startup--ED

well they should rev up to about 1500 for start.. then settle to around 900.. then gradually return to base idle as they warm up.

Controlled by the water temp sensor initially, once that threshold is reached it then moves to the air temp sensor and adjusts accordingly.

The comp works out the best idle for cold running, then once that is met it adjusts the mixture and timing based on the air temp sensors plus the rest.

88 EA Falcon S
3.9litre CFI
5spd Manual

RIP my ol' esky.. many years of good service
eskyboi is offline  
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Similar Threads
Thread Thread Starter Forum Replies Last Post
Territory Launch (Comprehensive) RPO83 Territory 25 05-03-04 04:56 AM
question regarding ED and EF/L XR's blackout Australian Falcons 11 12-28-03 04:22 AM
temp gauge reads high due to ground problem? eyoungberg Ford Vans and Mini Vans | Ford Aerostar | Ford Freestar | Ford Galaxy | Ford Windstar 5 10-24-03 09:30 PM
ED into an EA Mallyboo General Tech 15 11-02-01 01:18 AM

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome