Hot Weather Problems - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 07-06-07, 11:25 AM Thread Starter
Registered User
Join Date: Jul 2007
Posts: 1
Hot Weather Problems

I Have A 2000 Ford Expidtion Here In Phx.,az. During The Cooler Months She Drives Fine But When We Get Hotter I Start Haveing Trouble With Lach Of Power, Motor Revs Up To 3000 To 3500 Rpm Before Shifting, All Gauges Are Fine What They Need To Be. Wondering If It Might Be A Vacume Line Or A Sensor Problem.

If Anyone Has Any Ideas It Sure Would Be Helpful

CADMAN69 is offline  
Sponsored Links

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Gear in this thread - Powered by O'Reilly Auto Parts

Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome