i have a fuel problem could anyone help please? - Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars
Ford Forum Ford Forum

» Auto Insurance
» Featured Product
ยป Wheel & Tire Center

Go Back   Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech
Register Home Forum Active Topics Photo Gallery Auto Loans Garage Mark Forums Read Auto Escrow

General Tech Have a question that is not covered by one of the other categories? This is the forum for all other items not specifically covered in other categories.

FordForums.com is the premier Ford Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
Old 03-19-2005, 12:00   #1 (permalink)
Registered User
 
Join Date: Mar 2005
Posts: 10
Question i have a fuel problem could anyone help please?

ive got a ford fiesta si and its drinking an awful lot of fuel,i think itis more than likely the fuel filters clogged if its not any ideas wot it could be? also when i put my foot down the car looses power and is "jumpy" if thats the right word to use! which makes me think the fuels not getting through enough.
tasha si is offline   Reply With Quote
Sponsored Links
Advertisement
 
Old 03-20-2005, 15:36   #2 (permalink)
Registered User
 
Join Date: Dec 2004
Location: Auckland, New Zealand.
Posts: 61
Re: i have a fuel problem could anyone help please?

Sounds more like a misfire than a fuel problem, maybe a lead breaking down under load?
If the filter i sblocked, it will lessen the fuel getting through.
Blueblood is offline   Reply With Quote
Old 03-21-2005, 04:01   #3 (permalink)
NB & NCII V8 Fairlanes
 
Join Date: Feb 2001
Location: Bibra Lake Western Australia
Posts: 2,862
Re: i have a fuel problem could anyone help please?

Also check timing.
__________________
Regards Blue
Aussiblue is offline   Reply With Quote
Old 03-21-2005, 04:10   #4 (permalink)
Registered User
 
TruBlu351's Avatar
 
Join Date: Apr 2003
Location: Newcastle
Posts: 2,398
Re: i have a fuel problem could anyone help please?

Could just need a tune-up.

Are you running points in your distributor or an electronic ignition? If points, replace them if worn or reset gap.

Check timing.

Pull your spark plugs. A dodgy/oiled up one when all others are different/clean will indicate something wrong with that plug or ignition lead.

By the way.............welcome to the forum
__________________
XE Falcon
393 Tremec TKO 9"
TruBlu351 is offline   Reply With Quote
Sponsored Links
Advertisement
 
Reply

  Ford Forums - Mustang Forum, Ford Trucks, Ford Focus and Ford Cars > The Garage - Tech Forums > General Tech



Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Powered by vBadvanced CMPS v3.2.2

All times are GMT -7. The time now is 09:47.



Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO 3.6.0
Garage Plus vBulletin Plugins by Drive Thru Online, Inc.